[Nut-upsuser] Various NUT issues/questions

Scott Tuc Ellentuch at T-B-O-H ml at t-b-o-h.net
Sat May 13 03:15:32 UTC 2006

> > 	Ok, I did that. For what I can see/tell for FreeBSD,
> > they suggest to put it into the /etc/rc.shutdown script. So I
> > did that. I pulled the plug. It went onto battery, got to
> > 30% (Which I still think is incredibly high, still looking to
> > see how to reduce it). The machine did its shutdown, and then
> > killed the power and the UPS turned off. I plugged it back in
> > and the UPS/System came back. Well, the system SORT OF came back.
> > The filesystems were so corrupted that it wouldn't come up.
> > :-/ This won't do. I'm normally a 9 hour drive from here, and we
> > lose power even on clear sunny days... :-/ 
> > 
> > 	Is there anything I can do to let the machine shut down
> > all the way THEN the UPS? 
> Yes, of course, that's what you were *supposed* to do :)
> You have to put the command that yanks the power from the computer at
> the very *end* of your shutdown script, i.e., after all the file
> systems have been unmounted (or remounted read-only, in the case of
> the root file system, which hopefully contains the newhidups driver
> and upsdrvctl).
	If there is someone running FreeBSD, I'd like to hear where
they put it. From checking Google :

	(NetBSD, but FreeBSD acts the same)

	They all suggest putting it into the bottom of /etc/rc.shutdown .
So thats where I put it. I tried to research the shutdown procedure for
FreeBSD, and the best I could find was :


	Which again talks about rc.shutdown. I don't know what else
it does afterwards so I can stick it in someplace else. 

	So I put it where others suggest, and from where I could tell
was the right place. So now I know its the wrong place. But then 
does anyone know in FreeBSD where the right place is?
> In other words, you want to yank the power just before /sbin/halt or
> /sbin/reboot or whatever would be called (this is from Linux; might
> look different but similar in *BSD). 
	[INSTALL clip deleted...] 
> > I tried changing ups.delay.shutdown
> > to 2 minutes and found that its 2 minutes from when you set it,
> > and it seemed to be a "HARD" down.. I had to press the button
> > to get it to start up again.
> > 
> > 	I hate to be a pain, but I'm not sure if its the UPS
> > I was guided to choose, my lack of knowledge of NUT, or my
> > desire to have what isn't available.
> It's point 2, mostly, I am afraid :) -- Peter
	So thats what the mailing list is for. :) Why I'm
asking questions. Some get answered, some more haven't been.

		Thanks, Tuc

More information about the Nut-upsuser mailing list