[Nut-upsuser] Sweex 1000VA UPS

YvesDM ydmlog at gmail.com
Thu Nov 9 15:08:17 CET 2006

On 11/9/06, Arjen de Korte <nut+users at de-korte.org> wrote:
> > radius1:/etc/nut# /lib/nut/genericups -a ups_name
> > Network UPS Tools - Generic UPS driver 1.30 (2.0.1)
> > No upstype set - see help text / man page!
> The last line should ring a bell, don't you think so?

Yes so I've tried man nut :-)

> Honestly, you didn't read the genericups man page, did you? You can't
> specify an upstype like this (the correct way is explained in the man
> page).

See above...ok now I did.

> In short, each configuration parameter in this file should be on a
> separate line, like the following:
> [ups_name]
>     driver = genericups
>     upstype = 7
>     port = /dev/ttyS0
>     desc = "Sweex 1000VA UPS"

Ok, I tried this.
The driver was loaded and..... the server shutdown immediately.
I had to attach a screen and a keyboard to the server and boot it in single
user mode
to disable nut in /etc/default/

Also make sure that NUT is able to access the serial port, so you may want
> to check permissions:
>     ls -l /dev/ttyS0

This gives me:

 radius1:/var/log# ls -l /dev/ttyS0
crw-rw----  1 root dialout 4, 64 2005-02-26 07:39 /dev/ttyS0

So, I guess not good. What is the correct chown?
chown root:nut /dev/ttyS0 ?

Could this be the reason of the instant shutdown?
I don't want this to happen again. (radius)

Kind regards,
> Arjen
> PS  Please keep the mailinglist posted. Others may benefit from problems
> (and solutions) you have with configuring NUT to get your UPS working.

Of course.
Many tnx

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20061109/b0c3e58f/attachment.htm

More information about the Nut-upsuser mailing list