[Nut-upsuser] Ups not shutting down

tehnic at occidentalconsulting.com tehnic at occidentalconsulting.com
Wed Jun 13 09:31:48 UTC 2007

>>> I saw that nut runs a ups shutdown sequence before the server shuts
>>> down.
> Yes. It looks like your UPS doesn't respond to that at all.
>>> If i run upsdrvctl shutdown nothing happens. For a moment the link with
>>> the ups is lost but after several seconds it connects again as if
>>> nothing happened.
> That is bad.
>>> I tried with upscmd also but i still cannot shutdown the ups.
> That is really bad. I just peeked in the sources and noticed that the
> default for offdelay is zero (0). From other, unrelated UPSes, I know that
> some require a non-zero argument here. You might try passing the
> 'offdelay' to the driver and set it to '1' for instance, to see if your
> UPS powers off then.
> Changes are that your UPS requires a special sequence to power down, one
> that we currently don't know of. If software was provided with this UPS by
> the manufacturer (most likely for Windows), you could try and sniff
> whatever it is sending to reboot the UPS or shut it down. Portmon is your
> friend here.
> If all else fails, your could use a method that is described in the FAQ.
> After sending the 'upsdrvctl shutdown' command in the halt script, wait
> for about 10 minutes and then reboot. If the UPS is really on battery,
> this is probably sufficient to drain the batteries completely and make it
> shutdown by itself. If the mains has returned in the mean time, it will
> just reboot. This is a huge kludge though.
> Best regards, Arjen
> --
> Eindhoven - The Netherlands
> Key fingerprint - 66 4E 03 2C 9D B5 CB 9B  7A FE 7E C1 EE 88 BC 57

I can't seem to find the method described in the FAQ !
I presume you were talking about this faq >

More information about the Nut-upsuser mailing list