[Nut-upsuser] Tripp-Lite SU6000RT4U - not supported?

Kevin DeGraaf kevin at kdegraaf.net
Fri Mar 9 21:34:27 CET 2007

> I think that Tripp Lite HID and "-x explore" were added in 2.0.5 or later.
> Which OS/distribution are you using?

Debian "Sarge" (3.1r1) GNU/Linux with nut-2.0.4.

I tried compiling 2.0.5 from source and received the following errors:

# gcc -I../include -O -Wall -Wsign-compare  -c newhidups.c

In file included from newhidups.c:25:
libhid.h:50:18: error: usb.h: No such file or directory
In file included from newhidups.c:25:
libhid.h:51: error: syntax error before 'hid_dev_handle'
libhid.h:51: warning: type defaults to 'int' in declaration of
libhid.h:51: warning: data definition has no type or storage class

[ ... Snipped; full output at http://kdegraaf.net/nut1.txt ... ]

The only "usb.h" on my system is in /usr/include/linux, so I tried
adding this to the gcc invocation:

# gcc -I/usr/include/linux -I../include -O \
  -Wall -Wsign-compare  -c newhidups.c

In file included from /usr/include/asm/fcntl.h:8,
                 from /usr/include/linux/fcntl.h:4,
                 from ../include/common.h:30,
                 from main.h:1,
                 from newhidups.c:24:
/usr/include/asm-x86_64/fcntl.h:69: error: syntax error before 'off_t'
/usr/include/asm-x86_64/fcntl.h:71: error: syntax error before 'l_pid'

[ ... Snipped; full output at http://kdegraaf.net/nut2.txt ... ]

Am I doing something wrong, or is this system (installed by a former
sysadmin) too old to compile nut-2.0.5?


Kevin DeGraaf

More information about the Nut-upsuser mailing list