[Nut-upsuser] Nut problems with Centos and Belkin UPS

Tomáš Smetana tsmetana at redhat.com
Mon Nov 26 13:10:11 UTC 2007

On Mon, 26 Nov 2007 21:36:29 +0900
Richard Chapman <rchapman at aardvark.com.au> wrote:

> Hi Arjen
> Also for Tomas Smetana of the epel repository
> I think we are getting somewhere - but not quite to the final goal...
> If I run:
> /sbin/usbhid-ups -u root -DDDDD -a BelkinUps
> as suggested it all works fine - and finds the UPS on the USB port.
> It still does so if I remove all the -DDDDDs.
> However - if I run it without the -u root - it will not find the UPS.
> When I run the provided startup script (action) - it behaves very
> much the same as when I run the above command without the "-u root"
> option. I am running the script as root (I think). It appears to me
> that maybe the script is not running the driver as root for some
> reason, or maybe the user it runs as has insufficient rights. I have
> had a quick look at the script but it isn't obvious how or where it
> runs the driver, so I will need to look further. Does anything
> obvious spring to mind as to why the standard startup action may be
> starting the driver as the wrong user? As far as I can see - the user
> "nut" and/or the group "nut" must have been created by the rpm
> install. I didn't knowingly create them. What user would you expect
> the driver to run as?
> I could attach the action script - but I'm not sure it will help.

The drivers are supposed to run under user "nut" group "uucp".  Your
problem seems to be somewhere in the udev rules provided with the rpm
package -- they should change the ownership and permissions of the
appropriate USB devices.  If you have your UPS attached
on /dev/bus/usb/003/002 then ls -l /dev/bus/usb/003/002 should say:
crw-rw---- 1 root uucp 189, 257 2007-11-26 14:05 002
(i.e. mode 0660, group uucp)

I will try to find out what's exacly wrong.  But everything points to
the udev rules.  Sorry for the inconveniences.


Tomáš Smetana
Base OS Software Engineer, Red Hat
RH IRC: #brno #devel #base-os; Freenode IRC: #fedora-devel

More information about the Nut-upsuser mailing list