[Nut-upsuser] Nut problems with Centos and Belkin UPS

Arjen de Korte nut+users at de-korte.org
Mon Nov 26 13:25:47 UTC 2007

Richard Chapman wrote:

> Also for Tomas Smetana of the epel repository
> I think we are getting somewhere - but not quite to the final goal...
> If I run:
> /sbin/usbhid-ups -u root -DDDDD -a BelkinUps
> as suggested it all works fine - and finds the UPS on the USB port. It
> still does so if I remove all the -DDDDDs.
> However - if I run it without the -u root - it will not find the UPS.

In that case, there is a permissions problem. Most likely, this can be
fixed by adding the proper hotplugging/udev script, depending on what
your kernel uses. How this can be done is documented in the INSTALL file
and is basically the job of the person who packaged NUT. Generally
speaking, it involves creating a NUT user and providing 'configure' with
the user and group. From there on, the configure script will most likely
setup things for you. The only thing that remains is that the packager
places these files in the right directories.

Best regards, Arjen

More information about the Nut-upsuser mailing list