[Nut-upsuser] CyberPower 1500AVRT won't load driver!

Christian Frye root.mailinglist at gmail.com
Wed Nov 28 01:04:08 UTC 2007

Hello! I got my hands on a CyberPower 1500AVRT, and i'm trying to get it
connected to my Gentoo machine.
I've followed all the basic guides on setting up NUT and UPS' but have had
no luck.

My current ups.conf is:
        driver = cyberpower
        port = /dev/ttyS0
        desc = Workstation

Upon running /etc/init.d/upsd start or upsdrv start I get:

 * Starting UPS drivers ...
Network UPS Tools - UPS driver controller 2.2.0
Network UPS Tools - CyberPower driver 1.00 (2.2.0)
Giving up on hardware detection after 3 tries
Unable to get initial hardware info string
Driver failed to start (exit status=1)
 * Failed to start UPS drivers!

I know it's on ttyS0(I only have one port, but the other 3 ttyS' compiled in
the kernel timeout after about 1 second). ttyS0 takes about 15seconds to
I also tried connecting it via USB but had no luck either, don't believe its
supported for this model. Have also tried powerpanel and cpsups drivers.

Any advice here, would be much appreciated! Thank you!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20071127/13286c26/attachment.htm 

More information about the Nut-upsuser mailing list