[Nut-upsuser] CyberPower 1500AVRT won't load driver!

Richard Chapman rchapman at aardvark.com.au
Wed Nov 28 05:11:08 UTC 2007

I can't really help - but have a similar problem with a different UPS. I 
have a Belkin ups with belkinunv driver which claims to support my 
model. I get a different error - but essentially the same issue. It just 
doesn't seem to get anything back from the UPS on ttyS0. I have checked 
the permissions on ttyS0 and they appear correct. I find this a bit 
puzzling - because I can't figure out how these permissions got set. How 
did it know that I wanted to use ttyS0, apparently before I ever told it 
what port to use?

I also have only one physical serial port on the box - though the device 
manager reports 2 16550 ports. I can't really find a way to definitively 
prove that the port on the back is ttyS0 - so any ideas how to do this 
would be appreciated. Are there any settings that can be set for ttyS0, 
such as baud rates etc, and if so - how is this done? I am relatively 
new to Linux - so pleas be gentle with me...:-)

Many thanks


Christian Frye wrote:
> Hello! I got my hands on a CyberPower 1500AVRT, and i'm trying to get 
> it connected to my Gentoo machine.
> I've followed all the basic guides on setting up NUT and UPS' but have 
> had no luck.
> My current ups.conf is:
> [cyberpower-gentoo]
>         driver = cyberpower
>         port = /dev/ttyS0
>         desc = Workstation
> Upon running /etc/init.d/upsd start or upsdrv start I get:
>  * Starting UPS drivers ...
> Network UPS Tools - UPS driver controller 2.2.0
> Network UPS Tools - CyberPower driver 1.00 (2.2.0)
> Giving up on hardware detection after 3 tries
> Unable to get initial hardware info string
> Driver failed to start (exit status=1)
>  * Failed to start UPS drivers!
> I know it's on ttyS0(I only have one port, but the other 3 ttyS' 
> compiled in the kernel timeout after about 1 second). ttyS0 takes 
> about 15seconds to timeout.
> I also tried connecting it via USB but had no luck either, don't 
> believe its supported for this model. Have also tried powerpanel and 
> cpsups drivers.
> Any advice here, would be much appreciated! Thank you!
> ------------------------------------------------------------------------
> _______________________________________________
> Nut-upsuser mailing list
> Nut-upsuser at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/nut-upsuser

More information about the Nut-upsuser mailing list