[Nut-upsuser] Working UPS report: Geek Squad GS-700U (Cyberpower clone?)

Victor Rehorst chuma at chuma.org
Fri Oct 5 17:08:23 UTC 2007


I wanted to report some success with monitoring this UPS, a "Geek Squad" 
brand GS-700U that I purchased earlier this year from Best Buy Canada.  
Information about this... thing is very scarce so here is what I know:

The unit itself is probably made by Cyberpower.  It has a 9-pin serial 
port on the UPS, as well as a serial-USB adapter thing.  I cracked open 
the serial-USB adapter and printed on the PCB inside is "CYBERPOWER USB 
1.7" which was a major tip-off. 

I'm using nut 2.2.0 on a Pepper Pad 2 - which is a UMPC type device 
based off of an Intel XScale CPU with a modified version of  MontaVista 
Linux Pro 3.1. (Linux kernel, gcc 3.4, *no* udev).  The serial 
port I used was actually a Belkin F5U103 USB to Serial port adapter.  I 
compiled nut against libusb 0.1.12.

Using the serial cable connected to a serial port, I was able to get NUT 
monitoring it with the "genericups" driver with upstype=7 (CyberPower 
Power99).  At lease, the On-Line / On Battery status works with this 
upstype setting - I haven't yet tested any of the other signals.

The serial-USB thing is identified as 0764:0005 on the USB bus, which is 
supposed to be identified by usbhid-ups.  However, when trying to use it 
I got USBDEVFS control errors in the system logs, the same as this 
previous post:


I also tried the cyberpower driver and cpsups driver with no luck.

I have never tried to use the included Windows software that came with 
the UPS, so I don't know if it even supports non-contact closure 
features like voltages, load percentages, etc.  I suppose I could try it 
out in a VMWare virtual machine running XP and see what it does...

Victor Rehorst - chuma at chuma.org - victor at newtontalk.net
Personal Homepage - http://www.chuma.org/ 

More information about the Nut-upsuser mailing list