[Nut-upsuser] usbhid-ups on openSUSE 10.3 does not see MGE Ellipse 1500

Roger Price rprice at cs.uml.edu
Wed Oct 17 10:37:28 UTC 2007

On Wed, 17 Oct 2007, Arjen de Korte wrote:

> This is a known problem with the new kernel in openSUSE 10.3:
> https://bugzilla.novell.com/show_bug.cgi?id=331749
> Unfortunately, this is apparently not very high on the list of priorities.
> So for now, I suggest to apply the changes by hand. :-(

I applied the change, and the head of file /etc/udev/rules.d now says:

   # udev rules for the NUT USB drivers

   ACTION!="add", GOTO="nut-usbups_rules_end"
   SUBSYSTEM=="usb_device", GOTO="nut-usbups_rules_real"
   SUBSYSTEM=="usb", GOTO="nut-usbups_rules_real"
   BUS!="usb", GOTO="nut-usbups_rules_end"


   # MGE UPS SYSTEMS - usbhid-ups
   SYSFS{idVendor}=="0463", .....

Again I tried to start usbhid-ups but I still get:

pastis:~ # /usr/lib/ups/driver/upsdrvctl -DDD start
Network UPS Tools - UPS driver controller 2.2.0-
Starting UPS: myups
exec: /usr/lib/ups/driver/usbhid-ups -a myups
Network UPS Tools: 0.28 USB communication driver 0.28 - core 0.30 (2.2.0-)

No matching HID UPS found
Driver failed to start (exit status=1)

Best Regards,

More information about the Nut-upsuser mailing list