[Nut-upsuser] Trouble with NUT?

Drew Vonada-Smith drew at whisperingwoods.org
Sat Oct 27 18:05:49 UTC 2007

I'm a linux newbie and having some trouble with NUT, can anyone assist?
I've read the FAQ and various articles online by Peter Sellinger and others
thoroughly.  OS is ClarkConnect 4.2, which is based on CentOS4/RHEL 4.  UPS
is an APC SmartUPS 1500 (USB).  Correct driver is believed to be
usbhid-ups.  No RPM for my OS was available past 2.0, so I built from source
using NUT 2.2.  I think this all worked OK, did not see anything suspicious.
(But again, compiling on linux is also new to me.)   PC is a pretty generic
ASUS motherboard with an AMD X2 proc and nVidia chipset (MCP55 USB).  


The setup had some USB issues causing initial confusion.  I'm running a
workaround to get EHCI and OHCI loaded instead of UHCI;  USB appears fine
now, although I am not successful using hotplug.  CC does not use udev and
thus I presume should be using "old-style" hotplug scripts.  The scripts
look fine but I can never get the files to show as owned by "ups" as
described.  However, -u root workaround seems OK.  Concluded this was not a
core issue.


When I run:

upsdrvctl -u root start upsserver


all looks OK on results:

Network UPS Tools - UPS driver controller 2.2.0-

Network UPS Tools: 0.28 USB communication driver 0.28 - core 0.30 (2.2.0-)

Detected a UPS: American Power Conversion/Smart-UPS 1500 RM FW:617.3.D USB

Using subdriver: APC/CyberPower HID 0.9


But when I run:

upsd -u root


I get:

Network UPS Tools upsd 2.2.0-

not listening on port 3493


That's the correct IP for the local machine; same results if I use localhost
instead.  Of course, upsc and upsmon are also unsuccessful.  It feels like
I'm allllllllmost there.  Any ideas for me?  Thanks group!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20071027/9581f5f8/attachment.htm 

More information about the Nut-upsuser mailing list