[Nut-upsuser] Power failure and NUT not shutting down

Seann Clark nombrandue at tsukinokage.net
Tue Jul 1 17:22:02 UTC 2008

Arjen de Korte wrote:
> [...]
>> Jun 27 17:03:10 s_dgram at host.network.com upsd[14891]: Host
>> disconnected (read failure)
>> Jun 28 08:31:00 s_dgram at host.network.com upsmon[2327]: Startup successful
>> Ok, We can see a serious issue there... My UPS shut down everything, due
>> to failures with the drivers.
> No. Whatever the problem with the drivers may be, this won't shutdown the
> UPS. The upsmon client that is acting as master can either send it a
> command to shutdown, or it dies because of empty batteries. A driver
> failing to communicate with the UPS never will shut it down.
This also wasn't caused by the driver not talking to the UPS, but the 
hard down of the systems was caused by NUT not being able to effectively 
talk to the UPS, and NUT did not realize that the UPS went to battery, 
and subsequently powered down after receiving nothing from the connected 
system ( I presume that is what happened. The only facts I have 
currently on this is that the logs stop abruptly at 17:03 CST when the 
power failed and there was no other NUT statements that showed it was 
doing as it was supposed to be. This is only a portion of this, but it 
is all I see, since I didn't get back on site for two hours, due to the 
roads being so bad and so forth)
>> This has occurred for me since I put the
>> 'fixed' powerpanel driver patch in place.
> Well, in that case you have pretty much only yourself to blame here. Not
> testing your systems after setting up is a mistake, not fixing things if
> you know/suspect it isn't working correctly even worse. You've just found
> out the hard way that after setting up NUT, you *must* test your
> configuration.
Which is fully on my part, and I full accept that blame. I tested the 
UPS, but never got around to pulling the plug to see what would happen.
>> I run the RPM and have no
>> problem like what is shown above, just not able to talk to the UPS and
>> get the right value. Half the time with this I get errors of 'stale
>> data' with NUT now as well.
> You're not providing an awful lot of information here. Which version of
> NUT are you using? What is the driver/server/client showing at startup?
The version I started on was  2.0.5-7. This had the changed Cyberpower 
driver in it that wasn't compatible with my UPS and how it spoke. When 
switching to the powerpanel driver I ended up getting bad data. After  
working with the list a little bit, I grabbed and tested the modified 
powerpanel driver in the CVS (again, my fault for not getting off a dev 
version, I missed if it were streamlined into a release though) and the 
driver that reported that information is: Network UPS Tools -  
CyberPower text/binary protocol UPS driver 0.23 (2.3.0-1290) (output 
from powerpanel in the bin directory).
I get GREAT detail from the new driver, but I also get this in the logs 
from time to time (ever 3rd read or so)
Jun 28 10:27:41 s_dgram at host.network.com  upsmon[2328]: Communications 
with the UPS cyberpower1500 at host.network.com is up and ok
Jun 28 10:27:53 s_dgram at host.network.com  powerpanel[2321]: 
Communications with UPS lost: Status read failed!
Jun 28 10:27:53 s_dgram at host.network.com  upsd[2324]: Data for UPS 
[cyberpower1500] is stale - check driver
Jun 28 10:27:55 s_dgram at host.network.com  powerpanel[2321]: 
Communications with UPS re-established
Jun 28 10:27:55 s_dgram at host.network.com  upsd[2324]: UPS 
[cyberpower1500] data is no longer stale

The errors on that driver start is:
Network UPS Tools - UPS driver controller 2.3.0-1290
Network UPS Tools -  CyberPower text/binary protocol UPS driver 0.23 
Warning: This is an experimental driver.
Some features may not function correctly.

CyberPower UPS not found on /dev/ttyS0
Driver failed to start (exit status=1)

Like I said, last time I updated this was to test a driver. I haven't 
seen anything stable in place yet for this driver and this UPS 
(Cyberpower 1500AVR). The cpsups driver doesn't work with this either. I 
also know the UPS is able to be seen since the Cyberpower provided 
software for linux is working and seeing the UPS. (I don't have both 
suites going at the same time though.)

This UPS was tested and worked with NUT 2.1 and had no problems with the 
Cyberpanel driver for that branch. It was when 2.2 was released with the 
few updates and additions is when my UPS setup broke. I had worked with 
the list to test and provide input for this particular UPS, but as I 
have said, I haven't had time to download and read the changelogs to 
find out what main stable branch this fixed was put into.  The client 
and server start up without error messages.

>> This has been one heck of a bad way to test the UPS, I know that, but
>> right now I don't have much of a choice on this. What I need to know is
>> if the newest stable version of NUT has the patched powerpanel driver in
>> it, and if yes, I will test that.
> As far as I know, it will work. But from the sparse information above,
> this doesn't look like a driver problem. Providing the information asked
> for, will probably indicate where the problem lies.
> Best regards, Arjen
Biggest problem is the only working driver I have found for this is 
experimental at the last time I looked. When I have time I will update a 
system to the bleeding edge for all the software it houses, but most 
times what works, or appears to work is left behind.

Seann Clark
nombrandue at tsukinokage.net

More information about the Nut-upsuser mailing list