[Nut-upsuser] Cyberpower/powerpanel error: Data stale

Seann Clark nombrandue at tsukinokage.net
Mon Oct 27 18:54:56 UTC 2008

Kjell Claesson wrote:
> Den Monday 27 October 2008 17.59.44 skrev Seann Clark:
>> All,
> Hi Seann,
> 8<--------------------------------snip---------------------------------
>>     What I am seeing that is the problem now is that the driver starts
>> correctly, and initially displays information back from the UPS, but on
>> any subsequent reads of the UPS, I get the error:
>> Mon Oct 27-11:55:52-root at haruhi:ups> upsc cyberpower-ups
>> Error: Data stale
> I'm not so familiar with the cyberpower driver. But I looked in the svn
> and it seems that the powerpanel driver is on it's way to replace it.
> Think Arjen is the one that know all about this.
I had issues when the 2.2 version branched out, so I started using the 
powerpanel with that, and with some changes that Arjen did, everything 
worked out and seemed stable, the problem I ran into though was 
something corrupted that development driver on my system and it was no 
longer useful for anything. That and I needed to get a production node 
set up after a few power hits that I needed to get it up and stable. 
This UPS is protecting a home network, so I don't know if you could call 
this "production" and since it is set up to protect the servers on 
failure I was comfortable testing drivers on this.

>>     I have just started seeing this error as the ups was moved to a
>> newer system on a newer version of Fedora. the differences between the
>> version was it was working on 2.1.x and not on 2.2.x. I would fall back
>> to the old system but that was replaced due to catastrophic hardware
>> failure, that wasn't power related.
> If you can try out the powerpanel driver and report back what it say
> and if you get the same data stale.
> Or, is it possible that new setup inject noice into the communication cable?
> I hade this on one ups, where I got a ground-loop with the cable.
 If I use the powerpanel driver, it either dies, or fails to start.

Here is a sample from the syslog dealing with that:
Oct 25 02:37:21 haruhi upsd[9796]: listening on port 3493
Oct 25 02:37:21 haruhi upsd[9796]: Can't connect to UPS [cyberpower-ups] 
(powerpanel-cyberpower-ups): No such file or directory
Oct 25 02:37:21 haruhi upsd[9797]: Startup successful
Oct 25 02:37:25 haruhi upsd[9815]: not listening on port 3493
Oct 25 02:37:27 haruhi upsd[9797]: Connected to UPS [cyberpower-ups]: 
Oct 25 02:37:27 haruhi upsd[9836]: not listening on port 3493
Oct 25 02:37:28 haruhi upsd[9856]: not listening on port 3493
Oct 25 02:37:29 haruhi upsd[9876]: not listening on port 3493
Oct 25 02:37:34 haruhi upsd[9919]: not listening on port 3493
Oct 25 02:37:42 haruhi upsd[9797]: Data for UPS [cyberpower-ups] is 
stale - check driver
Oct 25 02:38:33 haruhi upsd[9797]: UPS [cyberpower-ups] data is no 
longer stale
Oct 25 02:38:35 haruhi upsd[9797]: Data for UPS [cyberpower-ups] is 
stale - check driver
Oct 25 02:39:14 haruhi upsd[10229]: not listening on port 3493
Oct 25 02:39:14 haruhi upsd[9797]: Rejecting TCP connection from

I fixed the "rejecting TCP connections" lines so that isn't important in 
those logs (Forgot to change ACL's) but, since powerpanel was the first 
driver I used before moving over to the cyberpower driver this morning, 
I have decent logs of this problem.

The cable has been run in a way that uses shielded Serial, and doesn't 
run across any noise generating items beyond FCC requirements (lights, etc).
>> Any help would be appreciated though, and I can provide even more
>> information if it is needed.
> Regards
> Kjell

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5614 bytes
Desc: S/MIME Cryptographic Signature
Url : http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20081027/f29eddc3/attachment-0001.bin 

More information about the Nut-upsuser mailing list