[Nut-upsuser] Megatec_USB on OpenBSD 4.3 - again...

ng-sup01 at mclink.it ng-sup01 at mclink.it
Tue Oct 28 08:44:04 UTC 2008

Hello again!

   Thanks to the precious help from Henning Brauer, I managed to solve
an issue with my UPS (a rebranded UPS speaking in Ablerex-ese over USB).
Under OpenBSD 4.3, the UPS was claimed by HID. Now that I recompiled the
kernel, adding a USB_quirk, this is what I get when I insert the USB

ugen0 at uhub0 port 2 "UIS_ABLER USB to Serial" rev 1.00/1.00 addr 2

So far, so good (Henning confirmed this).

Trouble is, when I run megatec_usb:

root at puffwall:~/nut-2.2.2 # drivers/megatec_usb -u _ups -a atlantisland
-DDDDDD Network UPS Tools 2.2.2 - Megatec protocol driver 1.5.14
Carlos Rodrigues (c) 2003-2008

Serial-over-USB transport layer for Megatec protocol driver
Andrey Lelikov (c) 2006, Alexander Gordeev (c) 2006-2007, Jon Gough (c)

debug level is '6'
No appropriate HID device found
No supported devices found. Please check your device availability with
and make sure you have an up-to-date version of NUT. If this does not
try running the driver with at least 'vendorid' and 'subdriver' options
specified. Please refer to the man page for details about these options
(man 8 megatec_usb).
Please report your results to the NUT user's mailing list
<nut-upsuser at lists.alioth.debian.org>.

This is my ups.conf:

    driver = megatec_usb
    port = /dev/tty00
    desc = "Atlantis Land 1501"

I tried, just in case, port = /dev/ugen0.00 but, as I have been pointed
before, this is irrelevant.

Here's the equivalent of a lsusb:
root at puffwall:~/nut-2.2.2 # usbdevs -vd
Controller /dev/usb0:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
VIA(0x1106), rev 1.00
 port 1 powered
 port 2 addr 2: low speed, power 100 mA, config 1, USB to
Serial(0x0000), UIS_ABLER(0x0001), rev 1.00

also made ugen r/w to user _nut, as suggested in a tutorial:
root at puffwall:~/nut-2.2.2 # ll /dev/ugen0*
crw-rw-rw-    1 root     wheel     63,   0 Jun  2 21:25 /dev/ugen0.00
crw-rw-rw-    1 root     wheel     63,   1 Jun  2 21:25 /dev/ugen0.01
crw-rw-rw-    1 root     wheel     63,   2 Jun  2 21:25 /dev/ugen0.02

I am a bit lost. Please note that I have the same UPS up and running
under Linux (same nut, 2.2.2), so I know it is supported. Thanks in
advance for any suggestions


More information about the Nut-upsuser mailing list