[Nut-upsuser] Usbhip-ups going wild

Antoine Gatineau antoine.gatineau at alcatel-lucent.com
Tue Aug 4 15:13:37 UTC 2009

Hello everyone,
I have nut and nut-client installed from rpm, up and running without any
error in the logs or at screen.
upsc gives me the state of the battery and stuff. It seems functional.
Is there something to do in order to verify the health of the whole chain?
(upsmon -> upsd -> upsdrv)
One last question, after installing the rpms, /var/state/ups is not created
and the rights are not given like it should. I was suprised to see that this
was not ntegrated in RHEL5 rpms... Is there some restriction to integrate
that configuration?


De : Arnaud Quette [mailto:aquette.dev at gmail.com] 
Envoyé : lundi 3 août 2009 21:46
À : Antoine Gatineau
Cc : nut-upsuser
Objet : Re: [Nut-upsuser] Usbhip-ups going wild

2009/8/3 Antoine Gatineau <antoine.gatineau at alcatel-lucent.com>

I tried to recompile without xorg-x11-devel and I get this error :
configure: error: libgd not found, required for CGI build.
It is indeed required for nut-cgi
udev-devel, however, is not required.

yup, you got me wrong: only the dbus-glib as to be removed. xorg-devel (or
xpm-devel) is needed for nut-cgi

Anyway I made it build correctly.
I attached nut.spec (modified for RHEL4) and nut.spec.ori (original spec
file for RHEL5) for info.
There were no %files entry for libhidups, libhid.usermap

these 2 are for hotplug. if you use udev, you don't need these.

and 20-ups-nut-device.fdi

this file is for HAL. so not needed too.

in the original spec file, so I added them. I'm not an rpm building expert
but I wonder how it could work...
I also removed hal, powerman and netxml-ups man page and related files as
they are not used in this package.
I didn't test it running yet but I expect it to be OK. I'll come back to you
with results. 
BTW, in the first answer to this (too?) long thread, Arjen said that there
were lot of bug fixes and performance improvement done since nut-2.2.0. Is
there a bug tracker to seek if my issues will be solved with this new one?

to be short: ChangeLog



Linux / Unix Expert R&D - Eaton - http://www.eaton.com/mgeops
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://www.debian.org
Free Software Developer - http://arnaud.quette.free.fr/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20090804/24423960/attachment.htm>

More information about the Nut-upsuser mailing list