[Nut-upsuser] Online Xanto S1000 Driver

Arjen de Korte nut+users at de-korte.org
Tue Feb 9 19:21:34 UTC 2010

Citeren Dennis Stadler <Dennisstadler op ortwonline.de>:

>>> I tried all the buildin drivers, also the driver for the driver for the
>>> Generic UPS, nothing worked for this UPS
>> Which NUT version? Which OS? Which interface?
> interface is RS232 (/dev/ttyS0)

Try the megatec driver, by running it with debugging enabled

     /usr/lib/ups/driver/megatec -u root -DDD -a upsname

and make sure you have read the relevant parts of 'man 8 nutupsdrv'  
and 'man 8 megatec' before asking for help.

> Nutversion is 2.2.2-74.2

This is really (too) old. If the above fails to detect your UPS,  
upgrade to nut-2.4.1. Probably the easiest route to do that, is grab a  
source RPM from a newer openSUSE version and rebuild that. After  
installing that, the 'blazer_ser' driver would be a much better choice.

Best regards, Arjen
Please keep list traffic on the list

More information about the Nut-upsuser mailing list