[Nut-upsuser] MGE Pulsar Evolution 1100 - USB - error sending control message

Stephen Fergusson (Smart Computer Systems Ltd) stephen at smartcom.co.nz
Sun Feb 21 01:55:32 UTC 2010

Hi all,

Have been using Nut on Linux for over ten years now and find it 
brilliant.  Thanks.

Just upgraded to 2.4.2 and have the 5 or 6 models of UPS's that we use 
(apcsmart, megatec, mge-shut, surgemax, digitus) all working including 
the MGE Pulsar Evolution 1100 on a USB connection using the usbhid-ups 
driver.  Running on SLES9.  Old but we still have a few servers out 
there running this.

The only problem I have noted is a syslog entry that gets posted 
constantly when working with the USB connections MGE...

Feb 21 12:05:30 g540-sles usbhid-ups[20918]: libusb_get_interrupt: error 
sending control message: Operation not permitted
Feb 21 12:05:35 g540-sles last message repeated 8 times
Feb 21 12:06:35 g540-sles last message repeated 15 times
Feb 21 12:06:47 g540-sles last message repeated 3 times

If I run usbhid-ups, upsd and upsmon as the root user, I get...

Feb 21 12:55:02 g540-sles usbhid-ups[15701]: libusb_get_interrupt: No error
Feb 21 12:55:34 g540-sles last message repeated 8 times
Feb 21 12:55:50 g540-sles last message repeated 4 times

If I use pollonly=1 in the ups.conf no errors at all, and all works.  I 
haven't tried the pollonly option on the RS232 models.

So, I am assuming I do have a permissions error with udev and am slowing 
working my way through that, but struggling.

Are these syslog messages important?  Should they be logging if there is 
no error?
Is pollonly OK to use for everyday use?


More information about the Nut-upsuser mailing list