[Nut-upsuser] Confusing Generic USB UPS cannot be matched

R. G. Newbury newbury at mandamus.org
Tue Nov 22 19:47:57 UTC 2011

On 11/22/2011 03:51 AM, Arnaud Quette wrote:
> Hi Geoff,
>> Made sure the user/group settings are correct.
>> # cat upsd.user
>> <snip>
>>         [nut]
>>                 password = nutpass
>>                 upsmon master
>> So what is the driver trying to match against? And can I amend any settings
>> to make it match? Can I provide any more info.
> as per your info (VID:PID), your device is not HID compliant and the
> driver should be blazer_usb.
> "port = auto" is still needed, though you can put any value you want
> (field not considered).
> cheers,
> Arnaud

Thanks for your help spotting that. I have made progress as a result but 
still at least one problem.

At first it would not work. I got a generic sort of error. I tried the 
powerpanel driver and it reported a permissions error. Turned out that I 
needed to chmod the entire route to the socket (chomd -R 644 
/dev/bus/usb) and delete the vendor etc id.

[root at tor2 ups]# cat ups.conf
         driver = blazer_usb
#       vendorid = 0001
#       productid = 0000
         port = /dev/bus/usb/004/002
         desc = "Nexxtech UPS"

So now:

[root at tor2 ups]# service ups restart
Stopping UPS monitor:                                      [  OK  ]
Stopping upsd:                                             [  OK  ]
Shutting down UPS driver controller:                       [  OK  ]
Starting UPS driver controller:                            [  OK  ]
Starting upsd:                                             [  OK  ]
Starting UPS monitor:                                      [  OK  ]


[root at tor2 ups]# ps -ae | grep upsmon
  3841 ?        00:00:00 upsmon
  3842 ?        00:00:00 upsmon
  4695 ?        00:00:00 upsmon
  4696 ?        00:00:00 upsmon

And  SUCCESS (?)

[root at tor2 ups]# upsc nexxtech
battery.voltage: 13.50
battery.voltage.nominal: 12.0
beeper.status: disabled
device.mfr: NEXXTECH
device.model: 6118507
device.type: ups
driver.name: blazer_usb
driver.parameter.pollinterval: 2
driver.parameter.port: /dev/bus/usb/004/002
driver.version: 2.6.2
driver.version.internal: 0.03
input.current.nominal: 3.0
input.frequency: 60.1
input.frequency.nominal: 60
input.voltage: 123.0
input.voltage.fault: 165.0
input.voltage.nominal: 115
output.voltage: 123.0
ups.delay.shutdown: 30
ups.delay.start: 180
ups.firmware: VER 1.00UL
ups.load: 40
ups.mfr: NEXXTECH
ups.model: 6118507
ups.productid: 0000
ups.status: OL
ups.temperature: 0.0
ups.type: offline / line interactive
ups.vendorid: 0001

Heh! This is looking good!


[root at tor2 ups]# upscmd -u nut -p nutpass nexxtech beeper.toggle
Unexpected response from upsd: ERR ACCESS-DENIED

And using nut at or nut at localhost gives the same result (even 
though upsd reports to syslog that nut at is logged into UPS 

And here I am stuck. THe user and password are correct for the 'nut' 
user on the system, and in the conf file. upsdrvctl and upsd start as 
does upsmon. But I cannot seem to actually control the unit with upscmd. 
upsc returns all sorts of nice info however!!

So near and yet so far! Any thoughts?


More information about the Nut-upsuser mailing list