[Nut-upsuser] Confusing Generic USB UPS cannot be matched

R. G. Newbury newbury at mandamus.org
Mon Nov 28 22:09:19 UTC 2011

On 11/27/2011 04:34 PM, Charles Lepple wrote:
> On Nov 23, 2011, at 10:13 AM, R. G. Newbury wrote:
>> On 11/22/2011 07:42 PM, Charles Lepple wrote:
>>>> [root at tor2 ups]# upscmd -u nut -p nutpass nexxtech beeper.toggle
>>>> Unexpected response from upsd: ERR ACCESS-DENIED
>>>> And using nut at or nut at localhost gives the same result (even though upsd reports to syslog that nut at is logged into UPS [nexxtech]
>>> The system 'nut' user can have its password locked - upsd won't consult /etc/passwd for passwords, just for username->uid lookups.
>>> I wonder if there is an extra copy of upsd floating around that is using an old upsd.users file. (Usually it complains that it can't bind to the port, but stranger things have happened.)
>> No. I did a full system find and the only upsd is in /usr/sbin and the only *.conf files are in /etc/ups.
> I didn't mean to imply there was a second upsd binary on the filesystem - only an extra copy of upsd in memory. It only reads the password file at startup, or after a SIGHUP:
> http://www.networkupstools.org/docs/man/upsd.html#_reloading

Executive summary: Did not help.

Report: I stopped the ups service and disabled it (chkconfig ups off). I 
then created a completely new user. Amended the conf files as required. 

Trying blazer_usb: did not start: permissions problem...
Ended up doing:  chmod -R 666 /dev/bus/usb/
                  chown -R nutty:nutty /dev/bus/usb/004

Added those commands to /etc/rc.d/rc.local as the status will be lost on 

Rebooted again.
This time blazer_usb worked when called from the command line.
Added service ups start to /etc/rc.d/rc.local after the chmod/chown 

Reached prior status, although now repeatable through a reboot cycle.

upsc gives output, upscmd -l works
upscmd -u nutty -p nuttypass nexxtech beeper.toggle
fails are before with ERR ACCESS DENIED.

Thanks for the pointers to the source code, and to the 'add hardware' link.
But without command ability, it's not much use...

More information about the Nut-upsuser mailing list