[Nut-upsuser] help with CyberPower 425HG

nut at johnea.net nut at johnea.net
Sun Oct 16 19:51:53 UTC 2011

On 2011-10-16 12:06, Ron wrote:
> Rebooting worked for me too.  Wish I had read this post earlier

Hi Ron,

I've been struggling with nut and CyberPower USB devices for over a year now.

You may find connection to the UPS on boot to be unreliable, sometimes it will
connect, other times it won't.

>From the thread: "Re: [Nut-upsuser] USB CyberPower"
Hi James,

I've worked extensively on getting a similar CyberPower UPS (same IDs) to play
well with nut.

The conclusion I ultimately came to is that if this UPS is not connected to by
it's driver within about 20sec, it drops off the USB bus and re-enumerates. This
causes an endless cycle of the UPS attaching and detaching. In archlinux, I was able
to make it work by placing the nut daemon at the beginning of the rc scripts,
before everything else. This caused it to be attached to before it dropped from
the bus. Once it was attached, everything worked.

IMHO, If you can, return it and get a different unit.

As the text above indicates, the time between the system powering up, and the
driver trying to connect to the UPS is critical. If this time is too long
(greater than about 20sec) the UPS will have already disconnected from the USB
and the connection will fail. Thereafter the UPS will continuously re-enumerate,
wait about 20sec then disconnect again, and continue an endless cycle of
re-enumerate/wait 20sec/disconnect.

One major factor in the length of the delay on power up, was my computer's DHCP
delay. I found if I could get the nut driver to load prior to my computer going
out for DHCP, then it would reliably connect on boot.

If you have a static Network IP address, then this DHCP delay is not a factor
for you.

Anyway, try to connect to the UPS first, before any other boot time activity.

Thanks for your post! Please pass along your ongoing experiences...


More information about the Nut-upsuser mailing list