[Nut-upsuser] bcmxcp_usb can not communicate with Eaton Powerware 5110

Greg Vickers daehenoc at iinet.net.au
Sun Jul 22 10:14:53 UTC 2012

Hi Arnaud,

On 18/07/12 20:59, Arnaud Quette wrote:
> I've just made a quick test on an Opengear ACM 50004-2 (ARM 
> supervision appliance).
> For the record:
> - uname -a: Linux acm5004-2 #1 Tue Feb 15 09:30:54 EST 
> 2011 armv4tl unknown
> - nut version: 2.4.3 (so bcmxcp_usb 0.23)
> - tried with a PW5110 (ups.firmware: Cont:00.50 Inve:01.50)
> and everything worked like a charm.
> That said, Charles and Kjell comments are fully valid.
> That is, try with the latest version (2.6.4). It has at least more 
> debug traces to help getting visibility.
I've tested with nut 2.6.4, with the same result, i.e. this driver can't 
communicate with the UPS.

What switches should I use with the driver to provide you the debug 
information?  More -D switches?
> Could you perhaps test the 5110 on your Ubuntu system, with a recent NUT?
OK, tested on the Ubuntu system and it works just fine!  My PW5110 has 
the same firmware versions as yours, and the Ubuntu system I tested on 
has kernel 3.2.0 on it and nut 2.6.3.  I'll see if I can get kernel 
3.2.0 on the RaspberryPi and report back.
> As a side note, I still hope to rewrite this driver, part of 2.8.0.
> It will however depend on my available time, and the progress on the 
> main 2.8.0 items...

More information about the Nut-upsuser mailing list