[Nut-upsuser] usb disconnects

Dorian White dorianwhit3 at gmail.com
Wed Apr 3 21:06:19 UTC 2013


just joined to the list, because i have a problem. :S
We have 2 exact same configuration: basic Fujitsu server + Eaton NV1000H
ups. OS is Debian Squeeze.  According to the driver list, the ups uses the
blazer_usb driver. I never tried nut before, so i read some of the docs,
and configured it manually.
The problem pops up when i try to simulate the power-outage. I just unplug
the ups' power, and... the usb devices reconnects, in this case it means
the keyboard and the ups itself. I don't know ... should this happen? I
thought that the ups should provide enough power to not interrupt

So, the udev changes/increments the ups' device number, and the blazer
can't reconnect to it. Most of the time. Sometimes it works, but mostly the
connection lost, and upsmon wont work anymore.

I ran blazer in debug mode, like blazer_usb -DD -a eaton. The strange thing
is, when i unplug the power, the new device appears in the blazer's output,
but  sometimes cannot match it. However i tried it with productid,
vendorid, serial, bus, novendor etc, no match found, but it's there. I
tried to change the pollinterval, no luck. Tried it with the default blazer
in squeeze, from sid and the experimental, same thing.

I cannot provide logs atm, but any advice should help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20130403/355efdf2/attachment.html>

More information about the Nut-upsuser mailing list