[Nut-upsuser] Can't claim USB device

Lee Gold leegold at operamail.com
Wed Aug 7 22:53:36 UTC 2013

The reboot worked. Thank You! 

Now I get:

$ sudo upsdrvctl start
[sudo] password for wsadmin:
Network UPS Tools - UPS driver controller 2.6.3
Network UPS Tools - Generic HID driver 0.35 (2.6.3)
USB communication driver 0.31
Can't chdir to /var/run/nut: No such file or directory
Driver failed to start (exit status=1)

I'm going to do:

mkdir /var/run/nut
chown root:nut /var/run/nut
chmod 770 /var/run/nut

Is this right? Are the chmod permissions correct?

Thanks again.

On Wed, Aug 7, 2013, at 12:25 PM, Tom Lane wrote:
> Lee Gold <leegold at operamail.com> writes:
> > Ubuntu Server 12.04, Nut installed with sudo apt-get install nut
> > ...
> > Tried this and got error message:
> > Can't claim USB device [0764:0501]: could not detach kernel driver from
> > interface 0: Operation not permitted
> Did you reboot after installing the nut package?  Just a couple days ago
> I connected up a USB UPS to a Red Hat machine, and then installed nut,
> and found that the kernel had already grabbed the device.  Apparently
> nut's hotplug definition files have to be in place at boot time to
> prevent
> that.  Maybe things work differently on Ubuntu, but it's worth a try.
> 			regards, tom lane

http://www.fastmail.fm - Or how I learned to stop worrying and
                          love email again

More information about the Nut-upsuser mailing list