[Nut-upsuser] USB device descriptor read error with Eaton 5E UPS

Charles Lepple clepple at gmail.com
Sat Aug 9 23:05:36 UTC 2014

On Aug 7, 2014, at 7:57 AM, Leith Bade <leith at leithalweapon.geek.nz> wrote:

> I have tried to plug it into every USB port (including the USB 3.0
> ones) and I still get these errors. I discovered that power cycling
> the UPS will fix it for a while, and also unplugging and replugging
> the USB cable will also fix it sometimes.

Error -32 is EPIPE, which means that the PC didn't see a reply from the device during the descriptor read. I don't know that we have ever successfully run one of these issues to ground.

When you plug into the non-3.0 ports, what HCD driver is it using?

I wouldn't recommend using a hub in production, but if you have an older USB hub lying around, does that help? Shorter cables are also useful, though low-speed USB 1.1 is pretty resilient to noise.

Also, if you can fix it without rebooting the PC, the issue is probably external to the PC.

> I have observed the problem on both an Asus P9D-I motherboard with the
> Intel C222 chipset and on the Asus H87M-E motherboard with the Intel
> H87 chipset.

Did you have a chance to check the NUT archives? I vaguely remember some motherboard-specific threads.

Charles Lepple
clepple at gmail

More information about the Nut-upsuser mailing list