[Nut-upsuser] Install problems (group permissions) with nut 2.7.2

Gene Heskett gheskett at wdtv.com
Fri Feb 20 04:23:22 UTC 2015

On Thursday, February 19, 2015 10:16:41 PM Charles Lepple wrote:
> On Feb 19, 2015, at 8:55 AM, Gene Heskett <gheskett at wdtv.com> wrote:
> > On Wednesday, February 18, 2015 08:11:13 PM Charles Lepple wrote:
> > [...]
> > 
> >> On recent Debian and Ubuntu with 2.7.2 and
> >> earlier, there was an issue where the udev rules file needed to be
> >> renamed from 62-nut* to 52-nut* in order to not be overridden by
> >> another set of rules. It lives somewhere like /lib/udev/rules.d
> > 
> > Charles; I assume this is the message you refered to, so I just
> > checked my wheezy at that location, and its already been done. ISTR
> > there was a udev update recently.  So wheezy, if up to date, looks
> > to be on top of it.
> Gene,
> As I mentioned to Rob, I got that backwards, and the file should be
> named 62-nut... to override the earlier defaults. (It is
> extra-confusing because we still have an IPMI rules file that starts
> with 52.)

I guess I didn't see that, thanks, done.

I haven't made much progress, got side tracked trying to print the .pdf 
and found that there is no known way in wheezy to make a duplex capable 
printer, actually print in duplex mode.  Almost $800 dollars and worthless 
on wheezy. I am asking a few ?? over that on their mailing list as it 
worked perfectly on ubuntu-10.04.4 LTS.

Wheezy is dead stable, but actually getting something done with it is 
almost always a maddening battle of wits.

I have a single sided printout, 88 pages of 24 lb, but IIRC my 3 hole 
punch, a good one, is out in the machine shed where I was last updating my 
LinuxCNC doc's. And its currently +2F & nearly a foot of snow to plow to 
go get it.  And of coarse I'll need to find a 3 ring binder that I can 
recycle to be a nut doc holder. 1 step forward seems to be a 2 step 
backwards in real life.

I don't even know if I am using the correct driver, the ups-scanner seems 
only to exist in my 2.7.2 src tree, but its not installed as its looking 
for a much older libssl than I now have.  And the error messages from an 
attempted start are so generic they aren't a lot of help.  So and so 
didn't start, but no reason why is given.

After mv'ing that file, I still get:
root at coyote:/etc/init.d# ./nut-server start
[ ok ] Starting NUT - power devices information server and drivers:  
(driver(s) failed). upsd.

Why can it not name the failed driver, so I would know to try another?

> - Charles

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

More information about the Nut-upsuser mailing list