[Nut-upsuser] Install problems (group permissions) with nut 2.7.2 [driver selection and starting]

Gene Heskett gheskett at wdtv.com
Fri Feb 20 18:04:35 UTC 2015

On Friday, February 20, 2015 08:40:50 AM Charles Lepple wrote:
> On Feb 19, 2015, at 11:23 PM, Gene Heskett <gheskett at wdtv.com> wrote:
> > Almost $800 dollars and worthless
> > on wheezy. I am asking a few ?? over that on their mailing list as it
> > worked perfectly on ubuntu-10.04.4 LTS.
> If you still have a backup of /etc from the Ubuntu install, there might
> be some clues in /etc/cups about the duplex settings (or which drivers
> support duplex, more likely).
> My printer is still chugging along from the grad school days where I
> didn't have nearly that much to spend on a printer, so I tend to do
> the manual duplex method: print odd-numbered pages, flip the stack
> over, make a sacrifice to the gods of static electricity, and print
> the even pages.
> > I don't even know if I am using the correct driver, the ups-scanner
> > seems only to exist in my 2.7.2 src tree, but its not installed as
> > its looking for a much older libssl than I now have.
> I can't say I really buy into the nut-scanner notion. For the amount of
> work that went into it, I feel that we could have written some better
> procedural documentation that would have worked with whatever tools
> were on hand. And I don't think it's capable of saying "try this
> driver, but if that doesn't work, here are the older ones that might
> also work".
> So let's do it the manual way. Brand name? Any vendor-included software
> that is currently being used as a beverage coaster? USB or serial? If
> USB, what does lsusb say about it? (Might have to run lsusb as root,
> if the udev permissions are working as intended.)

See previous post for dmesg report, Belkin something or other, here's a 
fresh copy:

[    4.242066] usb 2-3: Product: Belkin UPS
[    4.242069] usb 2-3: Manufacturer: Belkin 
[    4.336423] usb 1-2.3: new full-speed USB device number 8 using 
[    4.453420] usb 1-2.3: New USB device found, idVendor=0403, 
[    4.453425] usb 1-2.3: New USB device strings: Mfr=1, Product=2, 
> >  And the error messages from an
> > 
> > attempted start are so generic they aren't a lot of help.  So and so
> > didn't start, but no reason why is given.
> Don't laugh, but there are two levels of indirection between
> /etc/init.d/nut-server and the driver. There's the init script itself,
> and upsdrvctl. Both were optimized for starting several drivers.
> We probably should be more explicit in the documentation about the
> possibility of starting the drivers manually at first (or using
> upsdrvctl "-D", with the appropriate number of "-D"s to print the
> driver name). Once the driver works on its own (and you can add "-D"
> to that command line to get more detail), you can kill the driver
> (important) and either try upsdrvctl or jump straight to the init.d
> script.
> > After mv'ing that file, I still get:
> > root at coyote:/etc/init.d# ./nut-server start
> > [ ok ] Starting NUT - power devices information server and drivers:
> > (driver(s) failed). upsd.
> > 
> > Why can it not name the failed driver, so I would know to try
> > another?
> The debian maintainers switched to systemd from the init.d scripts,

Wheezy is still using init.d for 99% of it.

> and
> that caused a release-critical bug in the Debian package of NUT for
> new installations. (Upgrades from pre-systemd days just worked, but if
> NUT was not configured yet, the post-install script would error out.)
> They were not willing to drop back to the init.d compatibility
> wrappers (which I think Ubuntu is still using) so I don't know if NUT
> is even going to make it into jessie, the release after wheezy.
> So that doesn't really answer your question, but it should explain a
> bit of the mess behind the init scripts. (And at the same time, we
> have been trying to coordinate a release of NUT 2.7.3.)
> If you have a github account, I would recommend creating an issue so
> that we don't forget about printing the driver name(s) at startup:
> https://github.com/networkupstools/nut/issues

I don't have one of those critters, Charles.
> (The combination of cold temperatures and a recent power outage seems
> to have taken out the one UPS in the house that I can't easily replace
> without voiding warranties: the DC supply for the broadband
> connection. While pairing a bluetooth keyboard to a smartphone works
> for the occasional email, the screen is a bit small to actually do
> anything useful on github, and I need to stop staring at the tiny
> screen for a while.)

That has the fingerprints of an EMP coming in on the broadband cable.
> - Charles

I hear that, its warmed up a bit but it was -9F here this morning. We are 
hybernating or working on software for a 30 yo computer.  And currently 
waiting for the author of the software that hooks its printer facility up 
to a modern printer, my assembly listings leave single space, arrive on 
paper double spaced.  A nilmerg of some sort. But every thing I try to do 
on wheezy shows me something else broken.

I have no clue how so much stuff can be broken and its still as stable as 
the rock of Gibralter.  Figuratively, every time I turn a wheel, I have to 
go find another box of lug nuts, they changed the thread pitch or 
whatever. Nowhere near as bad as fedora though.

d2u.sh was missing, and its not even in the repos for wheezy.  Grrrrr.

As for the power outages, I no longer worry too much about those. The 
missus has COPD and I installed a 20kw whole house nat gas standby late 
last winter.  So power outages in excess of 5 seconds are very rare now.

Still has the OEM oil in it, will get changed to 5w20 synthetic on the 
first 65F day. Tons easier to start.  If you have to start something in 
cold weather, that stuff is pure magic.

Take care & keep warm.

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

More information about the Nut-upsuser mailing list