[Nut-upsuser] UPS/NUT with openSUSE 13.1

Roger Price roger at rogerprice.org
Sat Sep 5 09:12:48 UTC 2015

On Fri, 4 Sep 2015, Rob Groner wrote:

> Well, I tried the same script method with openSUSE 13.2, and it still did not execute.
> So I tried the system method, and it worked 1 time out of 3 attempts.  I captured the last failure:
> 2015-09-04T11:43:38.825317-04:00 linux-5048 upsdrvctl[1887]: Can't claim USB device [2a37:5110]: No such file or directory
> 2015-09-04T11:43:38.825970-04:00 linux-5048 upsdrvctl[1887]: Network UPS Tools - Generic HID driver 0.39 (
> 2015-09-04T11:43:38.826243-04:00 linux-5048 upsdrvctl[1887]: USB communication driver 0.32
> 2015-09-04T11:43:38.826934-04:00 linux-5048 upsdrvctl[1887]: Driver failed to start (exit status=1)
> 2015-09-04T11:43:38.827185-04:00 linux-5048 upsdrvctl[1887]: Network UPS Tools - UPS driver controller

I'm confused here - the Bash script, and the systemd service unit, are for 
_shutting down_ the system on power failure, but in the trace you are 
having a problem _starting_ the driver.

> Is it possible the USB bus is going away before that can execute?

I havn't tested with openSUSE 13.2 so there may be something in it which 
prevents the driver from connecting to the UPS.  Perhaps with a more 
detailed trace using the upsdrvctl -D option it may be possible to see 
more clearly.


More information about the Nut-upsuser mailing list