[Nut-upsuser] port for powercom

James Smith jsmith at cashwaggner.com
Wed Jul 20 14:07:08 UTC 2016

Ok, so I previously thought I had to use usbhid-ups but when I eventually got it going this is what I got:-

This Powercom device (0d9f/0002) is not supported by usbhid-ups.
Please use the 'powercom' driver instead.

So I switched to the powercom driver, but I have tried a whole bunch of likely suspects for the port setting, none of which have worked

Tried so far:-
com1 with these results:-

Network UPS Tools - PowerCom protocol UPS driver 0.13 (Windows-v2.6.5-5-7-g72f38
w32_serial_open (com1)
setting initial state on com1
0000005C = w32_serial_open (com1)
Warning: no locking method is available: No error [The operation completed succe
ssfully. ]
vmin_ 0, vtime_ 0
action 0
vtime 0, vmin 1

ReadTotalTimeoutConstant -2, ReadIntervalTimeout -1, ReadTotalTimeoutMultiplier
data receiving error (0 instead of 11 bytes)

Com3 gives same result, nothing else I have tried (com2, com4, com5, com6, usb, usb0, usb1, usb2, usb3) gives me any results.

Does anybody have any idea what port setting for powercom should be on a windows system?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20160720/af8afffc/attachment.html>

More information about the Nut-upsuser mailing list