[Nut-upsuser] Unable to find driver for a supported device

Nick Teague nick.teague at smartfox.us
Tue Oct 11 17:35:35 UTC 2016

Hello everyone,

I have a Tripp-Lite UPS (smart1500rmxl2ua) I'm trying to get working with nut.

This is a FreeBSD 10.3 box.  I've tried using the usbhid-ups<http://networkupstools.org/docs/man/usbhid-ups.html> driver but everytime I try to start up nut, I get this:

# upsdrvctl start
Network UPS Tools - UPS driver controller 2.7.4
Network UPS Tools - Generic HID driver 0.41 (2.7.4)
USB communication driver 0.33
No matching HID UPS found
Driver failed to start (exit status=1)

usbconfig sees the UPS:

# usbconfig
ugen0.1: <UHCI root HUB VIA> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen3.1: <EHCI root HUB VIA> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen2.1: <UHCI root HUB VIA> at usbus2, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen1.1: <UHCI root HUB VIA> at usbus1, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen0.2: <TRIPP LITE SMART1500RMXL2Ua TRIPP LITE> at usbus0, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON (60mA)

Here's the ups.conf

# cat ups.conf

 I've also tried the tripplite driver with no success.  Any ideas on what I'm missing?

Nick Teague
Network Administrator
Smartfox Solutions
office: 1-877-301-9993
fax: 1-256-301-9299
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20161011/a64b5175/attachment.html>

More information about the Nut-upsuser mailing list