[Nut-upsuser] Unable to use nut-2.7.4 with Eaton 5E1500I USB

Charles Lepple clepple at gmail.com
Mon Jun 19 13:22:00 UTC 2017

On Jun 19, 2017, at 4:02 AM, Manuel Wolfshant wrote:
> On 06/18/2017 05:42 PM, Charles Lepple wrote:
>> On Jun 16, 2017, at 6:12 AM, Manuel Wolfshant wrote:
>>> running autogen.sh was triggered automatically. but even if I do it explicitly, I still get:
>>> + autoreconf -i                                                                                          
>>> configure.ac:887: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body                     
>>> ../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...                                     
>>> ../../lib/autoconf/general.m4:2661: _AC_LINK_IFELSE is expanded from...                                  
>>> ../../lib/autoconf/general.m4:2678: AC_LINK_IFELSE is expanded from...                                   
>>> /usr/share/aclocal/libtool.m4:1022: _LT_SYS_MODULE_PATH_AIX is expanded from...                          
>>> /usr/share/aclocal/libtool.m4:4161: _LT_LINKER_SHLIBS is expanded from...                                
>>> /usr/share/aclocal/libtool.m4:5236: _LT_LANG_C_CONFIG is expanded from...                                
>>> /usr/share/aclocal/libtool.m4:138: _LT_SETUP is expanded from...                                         
>>> /usr/share/aclocal/libtool.m4:67: LT_INIT is expanded from...                                            
>>> /usr/share/aclocal/libtool.m4:102: AC_PROG_LIBTOOL is expanded from...                                   
>>> configure.ac:887: the top level           
>> This sounds like an autotools incompatibility. Which versions of autoconf, automake, libtool, etc. are you using?
> As I am a packager for Fedora & EPEL I usually try to rely exclusively on the tools of the distribution ( RHEL / CentOS 6 in this case). Otherwise the packages would not be accepted as they could not be built using the official builders which use exclusively packages available in the distribution itself. In this particular case though I have updated some tools to versions from RHEL7 or Fedora so I am using:
>> autoconf-2.69-23.el6.noarch ( instead of distro's 2.63 )
>> automake-1.11.1-4.el6.noarch
>> libtool-2.2.6-15.5.el6.x86_64
>> libtool-ltdl-devel-2.2.6-15.5.el6.x86_64
>> m4-1.4.16-10.el6.x86_64 ( instead of 1.4.13 )
With the exception of libtool (I can never get the hang of libtool), I don't believe any of those packages are needed to compile from a tarball of NUT.

Looking at the backtrace, though, I think that NUT is only including AC_PROG_LIBTOOL, so it seems like that version of libtool and autoconf are not compatible. (On Fink, I am currently using autoconf-2.69 and libtool-2.4.6)

> - building against libusb 0.1 does not change in any way the situation, I still get the same error related to lack of ability to claim the interface

At some point, we took out a call to usb_set_altinterface() - the kernel is supposed to activate bAlternateSetting=0 automatically, and re-selecting it caused problems on other platforms. Maybe it was required with Linux kernel 2.6.x. With libusb-0.1 linked in, does "-x usb_set_altinterface=0" change anything?

More information about the Nut-upsuser mailing list