[Nut-upsuser] Help needed with NUT installation on Windows 10

Shimon Shtein shim4a at gmail.com
Thu Jan 23 05:30:10 GMT 2020

I had to override driver signature mechanism to install libusb driver, but
the device does not show any errors in device manager.

Is there any way to diagnose/debug this driver? Something that will try to
perform the same actions as NUT, but with very verbose output to see what
exactly went wrong there.

On Thu, Jan 23, 2020, 00:36 Douglas Parsons <doug at parsonsemail.com> wrote:

> First I have not worked with the Windows version at all. Just a note on
> drivers, did you look in device manager to see what it shows as the status
> on the device and it's driver?
> Have had issues with other gear and signed drivers. It may be Windows
> being overly protective.
> On Mon, Jan 13, 2020, 7:37 PM Shimon Shtein <shim4a at gmail.com> wrote:
>> Hello,
>> My setup is a Windows 10 machine, NUT installed from latest MSI.
>> UPS is Advice PRV650 connected with a USB cable.
>> I think the relevant log lines are:
>> C:\Program Files (x86)\NUT\bin>nut-scanner.exe
>> Cannot load USB library (libusb) : The specified module could not be
>> found.. USB search disabled.
>> I have tried to install winusb driver using zadig utility without any
>> success (the utility says the driver is successfully replaced, but the
>> error persists).
>> Any help would be much appreciated
>> _______________________________________________
>> Nut-upsuser mailing list
>> Nut-upsuser at alioth-lists.debian.net
>> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/nut-upsuser
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200123/c70ffefe/attachment.html>

More information about the Nut-upsuser mailing list