[Nut-upsuser] NUT-Server will not start at boot with Cyberpower PR1500

Paul Newbery newberype at hotmail.co.uk
Fri Mar 6 19:02:24 GMT 2020

O.S.:                      Linux LMDE 3 "Cindy"
Linux Kernel:        4.9.0-12-amd64
NUT Version:        2.4.7-5
Installed from:     Debian package
Driver in use:       usbhid-ups
UPS device:          Powerwalker Basic VI 1500 STL. Identifies as Cyberpower PR1500LCDRT2U UPS
VendorID              0764
ProductID             0601
Product URL:       https://powerwalker.com/?page=product&item=10121076&lang=en
Manufactured:     2019

Problem: I have been struggling for several weeks now to get these devices working satisfactorily. I purchased 2 of the units because the product information specifically stated that their "Powermaster" software worked with Ubuntu 18.04. I was using Linux Mint 19 at the time of purchase which is Ubuntu 18.04 based. I tried to get them working with this software on both Mint 19 and Ubuntu 18.04 and it just does not work. It talks to the UPS and all the settings can be set, but the UPSs would not perform an orderly shutdown of the computers. Product support in Germany could not help and have referred the issue to Taiwan which is now shut due to the Coronovirus outbreak. I am now using The Mint LMDE O.S. and cannot get them to work correctly on this O.S. either.

I have since been trying to get them working with the NUT software, which I can do, but I simply cannot get them to start at system start up. It can be seen from the "Syslog Nut Extract" that upsdrvctl successfully loads the driver, but nut-server fails to start and the driver then stops as it is no longer required. However, upsmon continues to load successfully and proceeds to fill up the syslog with error messages.

I can start everything post boot-up from a terminal by using the upsdrvctl, upsd and upsmon commands and everything then works properly. I have put this startup sequence into a script (attached) which also works well. I have been unsuccessful so far, in getting this script to run from crontab as root at boot time.

Any help will be much appreciated.

Paul Newbery

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200306/53f05243/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Syslog Nut extract
Type: application/octet-stream
Size: 3546 bytes
Desc: Syslog Nut extract
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200306/53f05243/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: upsc output
Type: application/octet-stream
Size: 913 bytes
Desc: upsc output
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200306/53f05243/attachment-0001.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: nutstart.sh
Type: application/x-shellscript
Size: 705 bytes
Desc: nutstart.sh
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200306/53f05243/attachment.bin>

More information about the Nut-upsuser mailing list