[Nut-upsuser] USB drivers not found when compiling

Jim Klimov jimklimov at cos.ru
Mon Mar 23 07:45:11 GMT 2020

On March 23, 2020 12:50:11 AM UTC, Tyler Montney <montneytyler at gmail.com> wrote:
>Came across this in the process of troubleshooting:
>My whole reason for compiling from source is to add SSL support (as it
>doesn't seem available through the package manager). Apt list shows
>libusb-1.0-0-dev/stable,now 2:1.0.22-2 armhf [installed]
>libusb-1.0-0/stable,now 2:1.0.22-2 armhf [installed]
>libusb-1.0-doc/stable,now 2:1.0.22-2 all [installed,automatic]
>Config.log shows this:
>configure:8538: checking for libusb version via pkg-config
>configure:8545: checking via libusb-config
>configure:8557: result: none found
>Tried compiling without USB, fails but now complains it can't find
>Apt list shows this installed:
>openssl/testing,now 1.1.1d-0+deb10u2+rpt1 armhf [installed]
>Compiling without USB or SSL compiles successfully. I assume NUT
>requires a
>specific version of these libraries, and if so, which versions are the
>right ones? Platform is a newly installed distro of latest Raspbian on
>Raspberry Pi 3. When I installed from the package manager, everything
>worked great (just missing the SSL support). I've been referring to

You mention compiling against libusb-1.0 but do not mention which NUT codebase you use. The master branch at the moment does not support it, only libusb-0.1 and there are some known connectivity stability bugs associated with that.

Currently there is a long-pending competition of several implementations, neither of which were merged yet since respective change authors did not consider their work perfect enough:





I believe you should pick whichever works for you (please report on those which do not work and how, if any), sync with current master should be possible for all of them.

Hope this helps,
Jim Klimov

Typos courtesy of K-9 Mail on my Android

More information about the Nut-upsuser mailing list