[Nut-upsuser] loss of communication

Joe Reid jreid at vnet.net
Tue Sep 15 02:12:37 BST 2020

rPi3 running current Buster.  I get this far:

# upsc networkups
Init SSL without certificate database
battery.charge: 100
battery.charge.warning: 30
battery.runtime: 2891
battery.type: PbAC
device.mfr: Vertiv Co
device.model: Liebert PST5
device.type: ups
driver.name: usbhid-ups
driver.parameter.pollfreq: 30
driver.parameter.pollinterval: 2
driver.parameter.port: auto
driver.parameter.productid: 0002
driver.parameter.synchronous: no
driver.version: 2.7.4
driver.version.data: Belkin/Liebert HID 0.17
driver.version.internal: 0.41
ups.mfr: Vertiv Co
ups.model: Liebert PST5
ups.productid: 0002
ups.status: OL
ups.vendorid: 10af

when I run
# service nut-client start
I begin getting these:
Broadcast message from nut at nabhas (somewhere) (Mon Sep 14 17:32:14 2020):

UPS networkups is unavailable

Broadcast message from nut at nabhas (somewhere) (Mon Sep 14 17:36:44 2020):

Communications with UPS networkups established

Broadcast message from nut at nabhas (somewhere) (Mon Sep 14 17:37:14 2020):

Communications with UPS networkups lost

Broadcast message from nut at nabhas (somewhere) (Mon Sep 14 17:41:44 2020):

UPS networkups is unavailable

Broadcast message from nut at nabhas (somewhere) (Mon Sep 14 17:47:14 2020):

UPS networkups is unavailable

When I originally set it up POLLFREQ and POLLFREQALERT were at 5 and 
DEADTIME at 15 (defaults) and I started getting these soon after service 
start.  After a few increases I adjusted them to 30, 30 and 90 and it 
took about 24 hours for the broadcasts to start.  During my early 
testing, when communications gots re-established automatically, the uspc 
command worked, but otherwise I got "stale results" error.  Restarting 
the services (nut-server and nut-client) resolved the issue, only to 
have the errors occur again.

FWIW, this rPi has an Adafruit Ultimate GPS Hat and is serving as a 
stratum1 ntp server,  as well as a secondary dns server.

Here is how I got here (post fresh rPi buster install and setting up ntp 
and bind):
apt-get install nut nut-monitor nut-cgi nut-snmp snmp-mibs-downloader

added to /etc/udev/rules.d/62-nut-usbups.rules from /lib/udev/rules.d/
ATTR{idVendor}=="10af", ATTR{idProduct}=="0002", MODE="664", GROUP="nut"

         driver = usbhid-ups
         port = auto
         desc = "Network Closet UPS"
         productid = 0002
         MONITOR networkups 1 upsmon pass master
         POLLFREQ 30
         DEADTIME 90

I've just set the POLLFREQ pair to 60 and DEADTIME to 180 and restarted 
the nut-server and nut-client services.  When I stopped them for this 
config refresh I did NOT get any errors shutting the services down (and 
I did stop/start not refresh).  In my earlier testing I did get errors 
about upsmon being dead when I tried to stop the server and client 
(didn't doc that specifically, sorry). I'm not finding any log files, 
but buster isn't my home; I'm old school Solaris migrating to illumos/OI 
on on my server.  Pointers to getting logging out of the services system 
and pointers on fixing this would be most appreciated.  I have a 2nd UPS 
to add to the network so I have a ways to go.


More information about the Nut-upsuser mailing list