[Nut-upsuser] install SNMP APC SMART UPS 2000 in XCP-NG dom0

Ken Brubacher ken at innovative.ink
Sat Dec 4 04:11:02 GMT 2021

A few days ago I configured Network UPS Tools in a Ubuntu VM on a XCP-NG VM. The driver installed flawlessly, and I was able to scan and find the UPS using nut-scanner -S -s -e

It returned the UPS configuration below from the network, and I configured ups.conf without a hitch. Because I want to send the shutdown command to my UPS, I need my NUT master installed in dom0, and I'm not trying to configure NUT inside of dom0 in XCP-NG host, and I'm having difficulty.

        driver = "snmp-ups"
        port = ""
        desc = "Smart-UPS X 2000"
        mibs = "apcc"
        community = "public"

On my Dell R740, I installed the following in dom0

yum install nut --enablerepo=epel,base,updates

When I run nut-scanner without parameters, it returns the two PSUs in the server (below)

        driver = "nut-ipmipsu"
        port = "id1"
        driver = "nut-ipmipsu"
        port = "id2"

When I run nut-scanner to find the SNMP UPS, it returns nothing

[23:04 milsrv01 ups]# nut-scanner -S -s -e
Cannot load XML library (libneon.so.27) : file not found. XML search disabled.
Scanning SNMP bus.
[23:05 milsrv01 ups]#

If I go ahead and configure ups.conf using the previously good config that worked in the Ubuntu VM, I get unknown mibs value: apcc

[23:06 milsrv01 ups]# /usr/sbin/upsdrvctl -DD start
Network UPS Tools - UPS driver controller 2.7.2
If you're not a NUT core developer, chances are that you're told to enable debugging
to see why a driver isn't working for you. We're sorry for the confusion, but this is
the 'upsdrvctl' wrapper, not the driver you're interested in.

Below you'll find one or more lines starting with 'exec:' followed by an absolute
path to the driver binary and some command line option. This is what the driver
starts and you need to copy and paste that line and append the debug flags to that
line (less the 'exec:' prefix).

   0.000524     Starting UPS: MILLRACKUPS01
   0.000569     1 remaining attempts
   0.000619     exec:  /usr/sbin/snmp-ups -a MILLRACKUPS01
Network UPS Tools - Generic SNMP UPS driver 0.72 (2.7.2)
Unknown mibs value: apcc
   6.042075     Driver failed to start (exit status=1)

Running the latest version of NUT in XCP-NG 8.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20211204/fe78b410/attachment.htm>

More information about the Nut-upsuser mailing list