[Nut-upsuser] install SNMP APC SMART UPS 2000 in XCP-NG dom0

Manuel Wolfshant wolfy at nobugconsulting.ro
Sat Dec 4 19:55:25 GMT 2021

On December 4, 2021 8:58:25 PM GMT+02:00, Ken Brubacher <ken at innovative.ink> wrote:
>Interesting. I didn’t check the version, just downloaded the version using yum. It seems like the driver I’m using is probably older than my UPS then and it’s not supported in that driver. How do I download a newer version using yum? Or do I have to compile it myself to get 2.7.4?

Activate the epel-testing repository and run yum update.


PS: the packages work just fine . epel ships nut-2.7.4 in its testing repo but beside me no one provided "good karma" as they call it (positive feedback via bodhi) in order to activate the automated mechanism which would have promoted the packages to stable.

>From: Jim Klimov <jimklimov at gmail.com>
>Sent: Saturday, December 4, 2021 10:32 AM
>To: Ken Brubacher <ken at innovative.ink>
>Cc: Arnaud Quette via Nut-upsuser <nut-upsuser at alioth-lists.debian.net>
>Subject: Re: [Nut-upsuser] install SNMP APC SMART UPS 2000 in XCP-NG dom0
>Given how driver says it has version 2.7.2, I have doubts about it being the "latest version" (latest official release 2.7.4 is about 5 years old now, cleaning up codebase for 2.7.5).
>Among things recently fixed in master branch, "Invalid mibs" may have meant no response to queries for OID - whether because device did not support that OID in its MIB, or did not recognize auth, or otherwise ignored the request (UDP is best-effort and does not help differentiate).
>Can't quickly say what could be wrong in that aged version, but I was recently told some APC devices might not handle the standard (fallback) IETF MIB, so maybe that build of the driver and the UPS indeed have nothing common to talk about.
>On Sat, Dec 4, 2021, 12:24 Ken Brubacher <ken at innovative.ink<mailto:ken at innovative.ink>> wrote:
>A few days ago I configured Network UPS Tools in a Ubuntu VM on a XCP-NG VM. The driver installed flawlessly, and I was able to scan and find the UPS using nut-scanner -S -s -e
>It returned the UPS configuration below from the network, and I configured ups.conf without a hitch. Because I want to send the shutdown command to my UPS, I need my NUT master installed in dom0, and I’m not trying to configure NUT inside of dom0 in XCP-NG host, and I’m having difficulty.
>        driver = "snmp-ups"
>        port = ""
>        desc = "Smart-UPS X 2000"
>        mibs = "apcc"
>        community = "public"
>On my Dell R740, I installed the following in dom0
>yum install nut --enablerepo=epel,base,updates
>When I run nut-scanner without parameters, it returns the two PSUs in the server (below)
>        driver = "nut-ipmipsu"
>        port = "id1"
>        driver = "nut-ipmipsu"
>        port = "id2"
>When I run nut-scanner to find the SNMP UPS, it returns nothing
>[23:04 milsrv01 ups]# nut-scanner -S -s -e
>Cannot load XML library (libneon.so.27) : file not found. XML search disabled.
>Scanning SNMP bus.
>[23:05 milsrv01 ups]#
>If I go ahead and configure ups.conf using the previously good config that worked in the Ubuntu VM, I get unknown mibs value: apcc
>[23:06 milsrv01 ups]# /usr/sbin/upsdrvctl -DD start
>Network UPS Tools - UPS driver controller 2.7.2
>   0.000000
>If you're not a NUT core developer, chances are that you're told to enable debugging
>to see why a driver isn't working for you. We're sorry for the confusion, but this is
>the 'upsdrvctl' wrapper, not the driver you're interested in.
>Below you'll find one or more lines starting with 'exec:' followed by an absolute
>path to the driver binary and some command line option. This is what the driver
>starts and you need to copy and paste that line and append the debug flags to that
>line (less the 'exec:' prefix).
>   0.000524     Starting UPS: MILLRACKUPS01
>   0.000569     1 remaining attempts
>   0.000619     exec:  /usr/sbin/snmp-ups -a MILLRACKUPS01
>Network UPS Tools - Generic SNMP UPS driver 0.72 (2.7.2)
>Unknown mibs value: apcc
>   6.042075     Driver failed to start (exit status=1)
>Running the latest version of NUT in XCP-NG 8.
>Nut-upsuser mailing list
>Nut-upsuser at alioth-lists.debian.net<mailto:Nut-upsuser at alioth-lists.debian.net>

More information about the Nut-upsuser mailing list