[Nut-upsuser] NUT Client Not Working, Server OK

Roger Price roger at rogerprice.org
Sun Feb 13 21:07:31 GMT 2022

On Sun, 13 Feb 2022, William Cole via Nut-upsuser wrote:

> I ran both:
> upsc 1LRES850 at
> upsc 2UCES750 at
> from the server's terminal - which is  In both cases the outcome was:
> Error: Connection failure: No route to host.

What does "upsc 1LRES850" do?  What is the output from "ifconfig -a" for the 
local network interface?

> Which is interesting as I can successfully ping both from .235.

ping uses the ICMP protocol's mandatory ECHO_REQUEST datagram to elicit an ICMP 
ECHO_RESPONSE from a host.  This is not the same TCP/IP protocol used by 
commands such as upsc.

> If it makes any difference, when I run sudo systemctl status nut-server from 235 [the server] it will show:
> upsd [506]: Connected to UPS [1LRES850] usbhid-ups-1

Surprising, I would expect to see

    upsd [506]: Connected to UPS [1LRES850] usbhid-ups-1LRES850

What happens on .235 if you type "upsc 1" ?


More information about the Nut-upsuser mailing list