<div dir="ltr"><div><div><div><div><div>Hi,<br><br></div>Thanks for help.<br></div>- I download the last version of NUT, 2.7.2.6<br></div>- I install library:    


        
        
        
        


<br>  nss-devel  


        
        
        
        


<br>  gcc-c++<br><br></div>So now I didn't get last errors on make.<br></div>But I get a new one when I try to do - make install<br>---------------------------<br><b>[root@artesano nut-2.7.2.6]# make install</b><br>Making install in include<br>make[1]: Entering directory `/home/artesano/Downloads/nut-2.7.2.6/include'<br>NUT_VERSION: "2.7.2.6"<br>test -f nut_version.h || cp _nut_version.h nut_version.h<br>cmp -s _nut_version.h nut_version.h || cp _nut_version.h nut_version.h<br>rm -f _nut_version.h<br>make  install-am<br>make[2]: Entering directory `/home/artesano/Downloads/nut-2.7.2.6/include'<br>make[3]: Entering directory `/home/artesano/Downloads/nut-2.7.2.6/include'<br>make[3]: Nothing to be done for `install-exec-am'.<br>make[3]: Nothing to be done for `install-data-am'.<br>make[3]: Leaving directory `/home/artesano/Downloads/nut-2.7.2.6/include'<br>make[2]: Leaving directory `/home/artesano/Downloads/nut-2.7.2.6/include'<br>make[1]: Leaving directory `/home/artesano/Downloads/nut-2.7.2.6/include'<br>Making install in common<br>make[1]: Entering directory `/home/artesano/Downloads/nut-2.7.2.6/common'<br>make[2]: Entering directory `/home/artesano/Downloads/nut-2.7.2.6/common'<br>make[2]: Nothing to be done for `install-exec-am'.<br>make[2]: Nothing to be done for `install-data-am'.<br>make[2]: Leaving directory `/home/artesano/Downloads/nut-2.7.2.6/common'<br>make[1]: Leaving directory `/home/artesano/Downloads/nut-2.7.2.6/common'<br>Making install in clients<br>make[1]: Entering directory `/home/artesano/Downloads/nut-2.7.2.6/clients'<br>make[2]: Entering directory `/home/artesano/Downloads/nut-2.7.2.6/clients'<br> /bin/mkdir -p '/usr/local/ups/lib'<br> /bin/sh ../libtool   --mode=install /usr/bin/install -c   <a href="http://libupsclient.la">libupsclient.la</a> <a href="http://libnutclient.la">libnutclient.la</a> '/usr/local/ups/lib'<br>libtool: install: /usr/bin/install -c .libs/libupsclient.so.4.0.0 /usr/local/ups/lib/libupsclient.so.4.0.0<br>libtool: install: (cd /usr/local/ups/lib && { ln -s -f libupsclient.so.4.0.0 libupsclient.so.4 || { rm -f libupsclient.so.4 && ln -s libupsclient.so.4.0.0 libupsclient.so.4; }; })<br>libtool: install: (cd /usr/local/ups/lib && { ln -s -f libupsclient.so.4.0.0 libupsclient.so || { rm -f libupsclient.so && ln -s libupsclient.so.4.0.0 libupsclient.so; }; })<br>libtool: install: /usr/bin/install -c .libs/libupsclient.lai /usr/local/ups/lib/<a href="http://libupsclient.la">libupsclient.la</a><br>libtool: install: /usr/bin/install -c .libs/libnutclient.so.0.0.0 /usr/local/ups/lib/libnutclient.so.0.0.0<br>/usr/bin/install: cannot stat `.libs/libnutclient.so.0.0.0': No such file or directory<br>make[2]: *** [install-libLTLIBRARIES] Error 1<br>make[2]: Leaving directory `/home/artesano/Downloads/nut-2.7.2.6/clients'<br>make[1]: *** [install-am] Error 2<br>make[1]: Leaving directory `/home/artesano/Downloads/nut-2.7.2.6/clients'<br>make: *** [install-recursive] Error 1<br>----------------------------<br><br><div><div><div><div><div><div><div class="gmail_extra"><br><div class="gmail_quote">2015-02-13 6:00 GMT-06:00  <span dir="ltr"><<a href="mailto:nut-upsuser-request@lists.alioth.debian.org" target="_blank">nut-upsuser-request@lists.alioth.debian.org</a>></span>:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Send Nut-upsuser mailing list submissions to<br>
        <a href="mailto:nut-upsuser@lists.alioth.debian.org">nut-upsuser@lists.alioth.debian.org</a><br>
<br>
To subscribe or unsubscribe via the World Wide Web, visit<br>
        <a href="http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser" target="_blank">http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser</a><br>
or, via email, send a message with subject or body 'help' to<br>
        <a href="mailto:nut-upsuser-request@lists.alioth.debian.org">nut-upsuser-request@lists.alioth.debian.org</a><br>
<br>
You can reach the person managing the list at<br>
        <a href="mailto:nut-upsuser-owner@lists.alioth.debian.org">nut-upsuser-owner@lists.alioth.debian.org</a><br>
<br>
When replying, please edit your Subject line so it is more specific<br>
than "Re: Contents of Nut-upsuser digest..."<br>
<br>
<br>
Today's Topics:<br>
<br>
   1. Re: Error installing Nut 2.7.2 on RedHat 6.6 (Charles Lepple)<br>
<br>
<br>
----------------------------------------------------------------------<br>
<br>
Message: 1<br>
Date: Thu, 12 Feb 2015 22:30:07 -0500<br>
From: Charles Lepple <<a href="mailto:clepple@gmail.com">clepple@gmail.com</a>><br>
To: Leopoldo Cantillo <<a href="mailto:leopoldo.cantillo@gmail.com">leopoldo.cantillo@gmail.com</a>><br>
Cc: <a href="mailto:nut-upsuser@lists.alioth.debian.org">nut-upsuser@lists.alioth.debian.org</a><br>
Subject: Re: [Nut-upsuser] Error installing Nut 2.7.2 on RedHat 6.6<br>
Message-ID: <<a href="mailto:71E3C0D2-9A68-45B8-8AA5-186717A804C6@gmail.com">71E3C0D2-9A68-45B8-8AA5-186717A804C6@gmail.com</a>><br>
Content-Type: text/plain; charset=us-ascii<br>
<br>
On Feb 12, 2015, at 9:20 PM, Leopoldo Cantillo <<a href="mailto:leopoldo.cantillo@gmail.com">leopoldo.cantillo@gmail.com</a>> wrote:<br>
<br>
> Hi,<br>
><br>
> I need help because I can't install Nut in RedHat EL 6.6<br>
> The version of Nut in repository ot RHEL is 2.6.5-2, but doesn't suppor my UPS,<br>
> Liebert GXT3-200RT.<br>
<br>
I think GXT3 support was added after 2.7.2 was released.<br>
<br>
Since you are building from source already, I recommend grabbing the latest snapshot from this page:<br>
<br>
<a href="http://buildbot.networkupstools.org/snapshots" target="_blank">http://buildbot.networkupstools.org/snapshots</a><br>
<br>
At the moment, it is 2.7.2.6 (we are working on releasing 2.7.3).<br>
<br>
> I read that it is supported using Nut version 2.7.2, but I looking all around the web how to install it in my RedHat but I didn't find answers.<br>
> Follow the guide, I can downlad lasted version stable on web: 2.7.2<br>
> Here the errors and info from terminal:<br>
> Thanks a lot for help me.<br>
> ----------------------<br>
> [artesano@artesano nut-2.7.2]$ ./configure --with-user=artesano --with-group=nut --with-usb<br>
> Network UPS Tools version 2.7.2<br>
...<br>
> checking for Mozilla NSS version via pkg-config... none found<br>
> checking for Mozilla NSS cflags...<br>
> checking for Mozilla NSS ldflags... -lnss3 -lnssutil3 -lsmime3 -lssl3 -lplds4 -lplc4 -lnspr4<br>
> checking for nss.h... yes<br>
> checking for NSS_Init... yes<br>
> checking whether to enable SSL support... yes (Mozilla NSS)<br>
<br>
There is a bug in our NSS detection - it found the wrong nss.h.<br>
<br>
Filed an issue so we don't forget: <a href="https://github.com/networkupstools/nut/issues/184" target="_blank">https://github.com/networkupstools/nut/issues/184</a><br>
<br>
You will need to install something like 'libnss-devel' (or maybe 'lib64nss-devel'?) to get the NSS headers and development library.<br>
<br>
--<br>
Charles Lepple<br>
clepple@gmail<br>
<br>
<br>
<br>
<br>
<br>
<br>
------------------------------<br>
<br>
Subject: Digest Footer<br>
<br>
_______________________________________________<br>
Nut-upsuser mailing list<br>
<a href="mailto:Nut-upsuser@lists.alioth.debian.org">Nut-upsuser@lists.alioth.debian.org</a><br>
<a href="http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser" target="_blank">http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser</a><br>
<br>
------------------------------<br>
<br>
End of Nut-upsuser Digest, Vol 116, Issue 10<br>
********************************************<br>
</blockquote></div><br><br clear="all"><br>-- <br><div class="gmail_signature">Leopo C.M.</div>
</div></div></div></div></div></div></div></div>