<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div class=""></div><div class=""><br class=""></div><div class=""><br class=""><div><blockquote type="cite" class=""><div class="">On Jul 28, 2015, at 10:10 PM, Charles Lepple <<a href="mailto:clepple@gmail.com" class="">clepple@gmail.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html charset=windows-1252" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">On Jul 28, 2015, at 12:13 PM, AIYL <<a href="mailto:adliyanes@gmail.com" class="">adliyanes@gmail.com</a>> wrote:<br class=""><div class=""><br class="Apple-interchange-newline"><blockquote type="cite" class=""><div class="" style="font-family: Helvetica; font-size: 14px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;">Before contacting Synology and Netgear/Readynas, I’d prefer to make sure that the NUT UPS Server has been setup correctly and that the “experimental” MACOSX-UPS driver is equivalent to a standard “usb” driver in terms of server/client communications.</div></blockquote><div class=""><br class="Apple-interchange-newline"></div><div class="">I flagged it "experimental" because the UPS-to-driver interface is not as robust as USB or serial, but that shouldn't affect the upsd-to-NAS connection. Once the driver starts, and assuming the UPS is not disconnected, things should work similarly to other drivers.</div><div class=""><br class=""></div><div class="">Gracefully handling disconnection is a known issue for the macosx-ups driver, and it is also known that the information provided by OS X is less detailed than what you would get from usbhid-ups on a non-OSX system. Hopefully the latter is not causing an issue: the NAS should not be relying on anything other than "ups.status" and possibly a few other variables.</div></div><br class=""><div class="">
<span class="Apple-style-span" style="border-collapse: separate; border-spacing: 0px;"><div class="">-- </div><div class="">Charles Lepple</div><div class="">clepple@gmail</div><div class=""><br class=""></div></span><br class="Apple-interchange-newline">

</div>
<br class=""></div></div></blockquote></div><br class=""></div></body></html>