<html>
  <head>
    <meta content="text/html; charset=windows-1252"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Try looking into your kernel log. I would suspect issues with the
    usbhid kernel module.<br>
    <br>
    This may help (depending on the kernel you are running):<br>
    <br>
    rmmod usbhid && modprobe usbhid quirks=0x0463:0xffff:0x8<br>
    <br>
    Jan<br>
    <br>
    <div class="moz-cite-prefix">On 26.4.2016 17:56, Ken Marsh wrote:<br>
    </div>
    <blockquote
cite="mid:CAMsrcMkGtVXsWy=OpAKZ_zqPGXbsdAgGsy66Ez588Z5nHqRL=g@mail.gmail.com"
      type="cite">
      <div dir="ltr">
        <div><br>
        </div>
        <div>I've used NUT successfully for monitoring many different
          brands of UPS, but this one has me stumped. It has the same
          manufacturer ID and Product ID as older supported MGE-type
          Eaton UPS's, but has trouble talking. I tried Ubuntu's repo
          NUT, and it logs a Connecting to UPS message every few seconds
          forever, but never really succeeds (or says it fails).
          Different failure mode after building latest NUT d/l, as shown
          below. I have a udev rule in place, restarted udev and have
          removed/replaced the USB cable.</div>
        <div><br>
        </div>
        <div>I'll try to lay out all the info here up front. If this
          requires more data for development, I'll do my best to provide
          it.</div>
        <div><br>
        </div>
        <div># lsusb:</div>
        <div class="gmail_signature">
          <div dir="ltr">
            <p><span></span></p>
          </div>
        </div>
        <div>Bus 007 Device 061: ID 0463:ffff MGE UPS Systems UPS<br>
        </div>
        <div><br>
        </div>
        <div>
          <div># cat 90-nut-ups.rules</div>
          <div># Eaton MGE 5S 1000LCD</div>
          <div>ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0463",
            ATTR{idProduct}=="ffff", MODE="0660", GROUP="nut"</div>
        </div>
        <div><br>
        </div>
        <div>
          <div># ls -l /dev/bus/usb/007/061</div>
          <div>crw-rw---- 1 root nut 189, 828 Apr 26 11:38
            /dev/bus/usb/007/061</div>
        </div>
        <div><br>
        </div>
        <div><br>
        </div>
        <div>
          <div># cat ups.conf</div>
          <div>[eaton]</div>
          <div> driver=usbhid-ups</div>
          <div> port=auto</div>
          <div> desc = "Eaton 5S"</div>
        </div>
        <div><br>
        </div>
        <div>
          <div># cat nut.conf</div>
          <div>MODE=standalone</div>
        </div>
        <div><br>
        </div>
        <div><br>
        </div>
        <div>#Log for 2.7.4</div>
        <div>
          <div>Apr 25 16:37:21 myhost upsd[20089]: Connected to UPS
            [eaton]: usbhid-ups-eaton</div>
          <div>Apr 25 16:37:21 myhost upsd[20089]: mainloop: polling 1
            filedescriptors</div>
          <div>Apr 25 16:37:23 myhost upsd[20089]: mainloop: no data
            available</div>
          <div>Apr 25 16:37:23 myhost upsd[20089]: mainloop: polling 2
            filedescriptors</div>
          <div>Apr 25 16:37:23 myhost upsd[20089]: Connected to UPS
            [eaton]: usbhid-ups-eaton</div>
          <div>Apr 25 16:37:23 myhost upsd[20089]: mainloop: polling 1
            filedescriptors</div>
          <div>Apr 25 16:37:25 myhost upsd[20089]: mainloop: no data
            available</div>
        </div>
        <div><br>
        </div>
        <div># NUT build info</div>
        <div>
          <p>mkdir -p /var/state/ups<br>
            chmod 0775 /var/state/ups<br>
            chown root:nut /var/state/ups</p>
          <p>apt-get install pkg-config<br>
            apt-get install libusb-1.0.0-dev</p>
          <p>wget <a moz-do-not-send="true"
href="http://sourceforge.net/projects/libusb/files/libusb-compat-0.1/libusb-compat-0.1.4/libusb-compat-0.1.4.tar.bz2"
              class="" rel="nofollow">http://sourceforge.net/projects/libusb/files/libusb-compat-0.1/libusb-compat-0.1.4/libusb-compat-0.1.4.tar.bz2</a><br>
            bunzip2 libusb-comp*<br>
            cd libusb-compat-0.1.4/<br>
            ./configure<br>
            make<br>
            make install</p>
          <p>wget <a moz-do-not-send="true"
              href="http://www.networkupstools.org/source/2.7/nut-2.7.4.tar.gz"
              class="" rel="nofollow">http://www.networkupstools.org/source/2.7/nut-2.7.4.tar.gz</a><br>
            gunzip nut-*<br>
            cd nut*4</p>
          <p>./configure --with-user=ups --with-group=nut --with-usb<br>
            make<br>
            make install<br>
            cp -p /etc/nut/*.users /usr/local/ups/etc/<br>
            /usr/local/ups/sbin/upsdrvctl start</p>
          <p>Network UPS Tools - UPS driver controller 2.7.4</p>
          <p>Network UPS Tools - Generic HID driver 0.41 (2.7.4)</p>
          <p>USB communication driver 0.33</p>
          <p>getpwnam(ups): Operation now in progress</p>
          <p>Driver failed to start (exit status=1)</p>
          <p><br>
          </p>
          <p># /usr/local/ups/bin/usbhid-ups -DD -a eaton</p>
          <p>Network UPS Tools - Generic HID driver 0.41 (2.7.4)</p>
          <p>USB communication driver 0.33</p>
          <p>   0.000000<span class="" style="white-space:pre"> </span>debug
            level is '2'</p>
          <p>   1.462780<span class="" style="white-space:pre"> </span>getpwnam(ups):
            Operation now in progress</p>
          <p># echo $?</p>
          <p>1</p>
          <p><br>
          </p>
          <p>Thanks in Advance,</p>
          <p>Ken</p>
          <p><br>
          </p>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Nut-upsuser mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Nut-upsuser@lists.alioth.debian.org">Nut-upsuser@lists.alioth.debian.org</a>
<a class="moz-txt-link-freetext" href="http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser">http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser</a></pre>
    </blockquote>
  </body>
</html>