[PATCH] Re: Remove duplicated code paths
nicolas.s-dev at laposte.net
Sat Dec 4 09:29:35 GMT 2010
On Wed, Dec 01, 2010 at 10:55:25AM +0100, Sebastian Spaeth wrote:
> Currently, account.syncrunner() has 2 separate duplicated code paths
> depending on whether we want to autorefresh after some waiting perios
> or not. Unify those code paths by setting "looping = False" in case
> self.refeshperiod == 0 after the first run. Behavior is identical to
> Signed-off-by: Sebastian Spaeth <Sebastian at SSpaeth.de>
> OK, to get us warmed up to the correct patch flow... This is a patch against current nicolas/master that does minor code simplification (saves us 15 lines of code, hurray :-)) and is pretty safe.
I like this kind of patch. :-)
> Would that be the best way to submit patches?
More information about the OfflineIMAP-project