Method names

Ethan Glasser-Camp glasse at
Sat Feb 5 16:24:44 GMT 2011

How do we feel about consistency of naming conventions in the code base? 
I see that most method names are wordsruntogether (ex: syncfolder, 
getaccountmeta), or wordsruntogether_specialversion (put_nowait, 
addmessagesflags_noconvert), but in general, Python (and PEP-8) 
encourages words_with_underscores. I'd prefer to use underscore-based 
names, but introducing them at this point ruins internal consistency, 
for the possible benefit of being more consistent with the Python 
ecosystem at some far-off future. But I'd really rather not use the 
current style for new code, seeing as it is, after all, not preferred 
for Python code.

What do you guys think? Will you reject patches if they conform to PEP-8? :)


More information about the OfflineIMAP-project mailing list