Problem with copying message to the server

Sebastian Spaeth Sebastian at
Thu Jan 27 11:15:10 GMT 2011

On Wed, 26 Jan 2011 21:40:33 +0100, Jiri Cerny <ji.cerny at> wrote:
> 2. in mutt move or copy a message from one copy of IMAP folder to
> another copy of IMAP folder
> 3. offlineimap again. When offlineimap copies the message to the
> server I get a python exception as in the log below.
> I tried with the current git version and I get the same error.

Did some  quick google search and it seems that the IMAP Exchange server
cannot take custom IMAP flags and responds to eg

19 APPEND test (\Answered \Seen NonJunk) "04-Sep-2009 16:02:06 +0200" {5876}
Read:   19 BAD Command Argument Error. 11


But this doesn't seem to be the case here, as you are not using any custom flags in:

APPEND TODO (\Seen) "26-led-2011 18:23:44 +0100" {3294}

Could it be that the localized date format confuses the Exchange server?

imap: savemessage: using date "26-led-2011 18:23:44 +0100"

in current git master in offlineimap/folder/, try to add at line
331 to test if this is the case (somewhere in the savemessage() function,
after the date has been set):

if date == "26-led-2011 18:23:44 +0100"
  date = "26-Jan-2011 18:23:44 +0100"

If the message saves fine with this international date, we know the

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <>

More information about the OfflineIMAP-project mailing list