IDLE command only runs once

Leon Bogaert leon at
Wed Sep 21 23:17:35 BST 2011

Hi all,

I'm currentyle using offlineimap against an Exchange server
(Exchange<->Dovecot) with the IDLE extension.

The problem is the IDLE command is triggered only once per refresh. If a
second new mail arrives before the refresh it isn't processed by

I did a "-d imap" but I didn't see anything odd. I tried to debug with
wireshark but even when I specified "ssl = no" the connection is
encrypted with tls so I couldn't see what was going on.

I've tried upping the number of connections very high: that didn't make
a difference.
I've cleaned my inbox so it only contains the message from 2011: didn't
make a difference.

I once spent an evening trying to debug the code but I couldn't really
pinpoint where it was going wrong. I found one thing out: if I commented
out the retrieving of new messages after an IDLE command it kept

I would really appreciate it if somebody could take a look at this. I
could provide them with a mailbox on my company's Exchange server.

Thanks in advance!


-------------- next part --------------
 Next refresh in 220 seconds
 Establishing connection to localhost:143.
 Syncing INBOX: IMAP -> MappedIMAP
Account sync timonline:
 Next refresh in 210 seconds
Copy message 4905 from INBOX:
 Copy message 4905 IMAP[INBOX] -> MappedIMAP[INBOX]
 Deleting 15 messages (3684,4869:4870,4874:4876,4882:4888,4890:4891) in IMAP[INBOX]
Account sync timonline:
 Next refresh in 200 seconds
 Next refresh in 190 seconds

More information about the OfflineIMAP-project mailing list