offlineimap hangs, several threads running then despite -1 flag

Jonny Törnbom jonny.tornbom at
Fri Jun 8 12:06:27 BST 2012


I'm currently running: Arch Linux with Kernel Linux 3.3.7-1-ARCH #1 SMP PREEMPT x86_64,
and Offlineimap hangs for me after ~5-10 minutes (no matter which UI, if run in background etc).
I'll explain what happens after a quick overview of my system:

My system has Python 2.7.3 and OfflineIMAP 6.5.4.
Remote server is an IMAP server with SSL:

Server welcome string: * OK Microsoft Exchange Server 2007 IMAP4 service ready
Server capabilities: ('IMAP4', 'IMAP4REV1', 'AUTH=NTLM', 'AUTH=GSSAPI', 'AUTH=PLAIN', 'IDLE', 'NAMESPACE', 'LITERAL+')

Local dir is Maildir (and I use Mutt as client).

I've been running the same config/server etc earlier on a Debian Stable system (with Python 2.6) and
I did not experience any problems then.

I've also been looking through the debug output when the problem occurs but it doesn't seem to give anything useful, so
for now i skipped to attach that, let me explain the problem first and ill attach one later on if necessary.

__The problem__:
I'm basically starting offlineimap with offlineimap -1. Now offlineimap starts to sync my account (i have 1 remote acc only),
with about 10 directories. All fine for lets say the first 10 couple of rounds. I'm currently using 5 minutes in between
autorefreshes (set to not keep connection open).
 After a while offlineimap just hangs at random places in the sync (it varies from every run), but now it stopped at
syncing my first directory, it just outputs:

*** Processing account hidden
 Establishing connection to
Folder Busybox [acc: hidden]:
 Syncing Busybox: IMAP -> Maildir

And I'm unable to CTRL-C, I have to pgrep the pid and kill it. This happens after a while _every_ time i run offlineimap.

I've made some interesting observations about the threading. From starters it only uses 1 thread as it should with -1, but
after a while I've seen it start up to 4-5 threads that then has died after the sync is complete. When offlineimap
hangs I'm now seeing 3 threads of: /usr/bin/python2 /usr/bin/offlineimap -1

The only useful information I found in the debug log this that gets outputed at an even interval when its hanged:
(Timestamps are wrong due to copy paste)

[imap]:   11:59.38 reader poll => []
[imap]:   11:59.38 reader poll => []

It's not after any particular message that this occurs, as it hangs after random time, but that output is constantly
written when its stuck. It only stucks when syncing though, so no hangs when it's counts down to refresh.

I did run an strace on it too and that only gave me that it stops on a FUTE_WAIT_PRIVATE call that never returns.

What is struggling me most is why it's running multiple threads despite -1 flag (I've also tried to hardcode
the singlethread variable to True in

Anyone have a clue about whats going on, has seen the issue themselves or know whats wrong?
(I should say that I've tried running without -1 flag and I _still_ get the hangs).

If there's anything you want to know, just tell me and I'll respond.



More information about the OfflineIMAP-project mailing list