No subject

Nicolas Sebrecht nicolas.s-dev at
Sun Jan 18 19:34:20 GMT 2015

On Sun, Jan 18, 2015 at 06:46:12PM +0100, mightyape at wrote:
> Hello,
> I am trying to backup my Emails from a Exchange Server. I can authenticate,
> but then I receive an error after a few Emails.
> I am using the Ubuntu Repository Version and I also tried the latest from
> GitHub (OfflineIMAP 6.5.7-rc1).



> Copy message from RemoteAccount:Archives/2011:
>  Establishing connection to
>  ERROR: list.remove(x): x not in list

Connection lost, implicit retry.

> Folder Archives/2011 [acc: Account]:
>  Copy message 8 (8 of 792) RemoteAccount:Archives/2011 -> LocalAccount
> Thread 'Copy message from RemoteAccount:Archives/2011' terminated with
> exception:
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/dist-packages/offlineimap/", line 156,
> in run
>   File "/usr/lib/python2.7/", line 763, in run
>     self.__target(*self.__args, **self.__kwargs)
>   File "/usr/lib/python2.7/dist-packages/offlineimap/folder/", line
> 330, in copymessageto
>     message = self.getmessage(uid)
>   File "/usr/lib/python2.7/dist-packages/offlineimap/folder/", line
> 253, in getmessage
>     self.imapserver.releaseconnection(imapobj)
>   File "/usr/lib/python2.7/dist-packages/offlineimap/", line 112,
> in releaseconnection
>     self.assignedconnections.remove(connection)
> ValueError: list.remove(x): x not in list

Could not release previous broken connection...

> Last 1 debug messages logged for Copy message from RemoteAccount:Archives/2011
> prior to exception:
> thread: Register new thread 'Copy message from RemoteAccount:Archives/2011'
> (account 'Account')

I'll have to check about that thread thing but it should be OK.

> ERROR: Exceptions occurred during the run!
> ERROR: list.remove(x): x not in list
> ------------------------
> I tried to google the error as it is quite common but I could not get a fix
> for it. What is causing this error and how can I solve this issue? At one
> point I could see my clear text password in the debug output like this
> imap: Attempting PLAIN authentication
> imap: __plainhandler: returning MY-USERNAME-AND-PASSWORD

Looks like something is wrong with your SSL configuration. This would explain
why it fallbacks to PLAIN mode...

...Or it's related with the thread thing above: the first error is raising an
exception, assumes it's because the SSL authentication failed and then fallbacks
to PLAIN mode.

Eygene submitted a patch to not fallback to other authentication modes when SSL
fails. You can expect a new release candidate in the coming days.

> The SSL config has never been diasabled. Is this an internal debugging message
> and or have my credentials have been transmitted in cleartext?

Your credentials have been transmitted in clear text.

> please let me know if you need further information.

Please test the patches I just wrote at

I'm not sure about the fix but first patch might help a bit in understanding the
root cause.

I'm not sure this bug is reproducible, though.

[PATCH 1/2] folder: IMAP: give better trace of errors while fetching
[PATCH 2/2] imapserver: fix race condition while releasing connection

More information about the OfflineIMAP-project mailing list