[Piuparts-devel] Bug#386839: The ~ character still doesn't work

Per Olofsson pelle at debian.org
Mon Feb 12 17:22:11 CET 2007

found 386839 0.20-3

Package: piuparts
Version: 0.20-3
Followup-For: Bug #386839


The ~ character still doesn't work in filenames as of version
0.20-3. I get this:

# piuparts -t /data1/pelle/tmp -p lyx-common_1.5.0~svn20070203-1_all.deb lyx_1.5.0~svn20070203-1_i386.deb
0m50.1s DEBUG: Copying lyx-common_1.5.0~svn20070203-1_all.deb, lyx_1.5.0~svn20070203-1_i386.deb to /data1/pelle/tmp/tmpmoAx-N/tmp
0m50.1s DEBUG: Starting command: ['chroot', '/data1/pelle/tmp/tmpmoAx-N', 'dpkg', '-i', 'tmp/lyx-common_1.5.0\\~svn20070203-1_all.deb', 'tmp/lyx_1.5.0\\~svn20070203-1_i386.deb']
0m50.8s DUMP:
  dpkg: error processing tmp/lyx-common_1.5.0\~svn20070203-1_all.deb (--install):
   cannot access archive: No such file or directory
  dpkg: error processing tmp/lyx_1.5.0\~svn20070203-1_i386.deb (--install):
   cannot access archive: No such file or directory
  Errors were encountered while processing:

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-amd64
Locale: LANG=C, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages piuparts depends on:
ii  apt                    Advanced front-end for dpkg
ii  debootstrap             Bootstrap a basic Debian system
ii  lsof                       4.77.dfsg.1-3 List open files
ii  python                     2.4.4-2       An interactive high-level object-o

piuparts recommends no packages.

-- no debconf information


More information about the Piuparts-devel mailing list