upgrade from jessie to stretch, problems that may related to accessibility

Al Sten-Clanton albert.e.sten_clanton at verizon.net
Thu Sep 14 21:33:26 UTC 2017

a11	Greetings!

When I was using jessie, I had the default of tty1 through tty6 as text 
terminals and tty7 for the gui.  Now, after trying and retrying to get 
stretch to work right, the gui is on different terminals with each 
reboot, and tty1 is useless except, apparently, for logging in.

Orca does not let me know when I'm at the login screen.  I guess how 
long after booting up I can log in.  After I've entered my userid and 
password, I get "screen reader on 14 pushbutton".  (The number may 
vary." As far as I can see, if I don't hit enter (presumably pushing the 
button), orca won't work aon any terminal.  If I do, I can use it on, 
say, tty2 or 3 or 4 or 7 but, as I said, never on 1.  Also, it seems 
that the only thing I can do is hit the enter key at that point:  trying 
to tab or arrow will show me no other options and cause no speech 
output.  (I noticed this button message on the stretch live CD as well, 
so I guess it's meant to be there, but I have no idea what its purpose is.)

I have set up my machine to disable pulseaudio, and have enabled 
espeakup.service.  Yet, the "ps -A" command shows "pulse" as one of the 
processes.  I think I made the changes in relevant files according to 
the instructions on the Decian accessibility wiki page, so this seems 
like it should not happen.  I acknowledge, though, that I first followed 
the instructions exactly, then tried to revert to using pulseaudio, then 
changed the files again to disable pulseaudio.  (It did not look like 
the dpkg-divert command did its job the second time, so I used mv to 
rename the pulse-alsa.conf file to pulse-alsa.conf.distrib; I was 
moderately sure this would work.)

I mention the bit about disable pulse because, although speakup mostly 
works, I get double and maybe triple speech output if I hit, say, the 
read-line key twice quickly to determine indentation on a line of 
programming code.  I also find that speakup reacts slower to keystrokes, 
such as the one to stop speech.

I think these comments describe my main problems with the upgrade.  I'll 
be grateful for any advice or pointers to information.  I hope I can fix 
the upgrade in the ways that I want without reinstalling; if not, then 
I'll have a couple of other questions.

A final note:  with jessie, I was able easily to revert to using 
pulseaudio.  When I tried it with stretch, I ended up without speech and 
could get even the half-working system I have now only by using the live 
CD and chroot.

Thanks for any help.


More information about the Pkg-a11y-devel mailing list