Bug#881099: libatk-adaptor: breaks LibreOffice TexMaths extension

Samuel Thibault sthibault at debian.org
Tue Apr 17 00:51:41 BST 2018

Control: reassign -1 libreoffice
Control: fixed -1 1:6.0.2-1+b1


Alex ARNAUD, le mer. 08 nov. 2017 14:01:48 +0100, a ecrit:
> Thank Paul for forwarding us this issue.
> I'm not sure it is due to libatk-adaptor itself. As I understand of the a11y
> stack on GNU/Linux, libatk-adaptor is the bridge between GTK applications
> and AT-SPI2. If libatk-adaptor is not installed, LibreOffice should provide
> no feedback to assistive technologies. So it seems it is an issue from
> LibreOffice itself.

I tend to think the same: atk-adaptor itself does not do much beyond
transmitting information from libreoffice to at-spi.  But that triggers
code inside libreoffice that wouldn't be executed otherwise, so I guess
the bug is only a side effect inside libreoffice of the presence of

I could reproduce the issue in Stretch indeed (atk-adaptor 2.22.0,
libreoffice 5.2).

I tried to reproduce the bug with Buster (atk-adaptor 2.26.2,
libreoffice 6.0.2), things worked fine.

I also tried to use the straightforward backport of buster's atk-adaptor
2.26.2 into stretch, and could reproduce the issue.

So I believe the issue really was in libreoffice, and is now away.


More information about the Pkg-a11y-devel mailing list