Bug#934376: gstreamer1.0-pocketsphinx: fails to load due to incompatible version

St├ęphane Alnet stephane at shimaore.net
Sat Aug 10 12:16:11 BST 2019


Package: gstreamer1.0-pocketsphinx
Version: 0.8+5prealpha+1-3
Severity: grave
Justification: renders package unusable

Dear Maintainer,

After installing the package, the `pocketsphinx` plugin fails to load.

It appears that the plugin is incompatible with the version of gstreamer
available in `testing`:

```
GST_DEBUG=4 gst-inspect-1.0 /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstpocketsphinx.so
[...]
0:00:00.063752136 31079 0x5645debd2c00 WARN      GST_PLUGIN_LOADING gstplugin.c:486:gst_plugin_register_func: plugin "/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstpocketsphinx.so" has incompatible version (plugin: 1.16, gst: 1,14), not loading
Could not load plugin file: File "/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstpocketsphinx.so" appears to be a GStreamer plugin, but it failed to initialize
```

To summarize: gstreamer is currently 1.14 in testing but 1.16 in unstable;
the pocketsphinx module is built using gstreamer 1.16; gstreamer 1.14
refuses to load a plugin built with gstreamer 1.16.

After installing the version of gstreamer available in unstable, the
plugin loads properly.

I suppose this could be fixed by updating the dependencies to match the
package's actual build dependencies, for example
  libgstreamer1.0-0 (>=1.16.0)
but I assume there may be better ways to do this.

Best regards,
St├ęphane

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gstreamer1.0-pocketsphinx depends on:
ii  libc6                           2.28-10
ii  libglib2.0-0                    2.60.6-1
ii  libgstreamer-plugins-base1.0-0  1.14.4-2
ii  libgstreamer1.0-0               1.14.4-1
ii  libpocketsphinx3                0.8+5prealpha+1-3
ii  libsphinxbase3                  0.8+5prealpha+1-4

gstreamer1.0-pocketsphinx recommends no packages.

gstreamer1.0-pocketsphinx suggests no packages.

-- no debconf information


More information about the Pkg-a11y-devel mailing list